zoukankan      html  css  js  c++  java
  • ACM2031_进制转换(使用了递归,代码超少的啦!!)

    进制转换

    Problem Description
    输入一个十进制数N,将它转换成R进制数输出。
     
    Input
    输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
     
    Output
    为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
     
    Sample Input
    7 2 23 12 -4 3
     
    Sample Output
    111 1B -11
     
    #include<iostream>
    using namespace std;
    void fun(int n,int r)
    {
    
        char st[17]="0123456789ABCDEF";
        if(n/r==0) cout<<st[n];
        else {
                fun(n/r,r);
                cout<<st[n%r];
                
             }
                                
    }
    int main()
    {
        int n,r;
        while(cin>>n>>r)
        {
            if(n<0)
                {
                    n=-1*n;
                    cout<<"-";
                }
            fun(n,r);
            cout<<endl;
        }
    }
     
     
  • 相关阅读:
    inner join on, left join on, right join on讲解(转载)
    ref 与 out
    Shell基础01
    Python 基础01
    linux基础03
    Shell基础02
    linux基础02
    Linux基础01
    linux基础05
    linux基础04
  • 原文地址:https://www.cnblogs.com/orangebook/p/3183962.html
Copyright © 2011-2022 走看看