zoukankan      html  css  js  c++  java
  • How Many Fibs_hdu_1316(大数).java

    How Many Fibs?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3098    Accepted Submission(s): 1232

    Problem Description
    Recall the definition of the Fibonacci numbers: 
    f1 := 1 
    f2 := 2 
    fn := fn-1 + fn-2 (n >= 3) 

    Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
     
    Input
    The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
     
    Output
    For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
     
    Sample Input
    10 100 1234567890 9876543210 0 0
     
    Sample Output
    5 4
     


    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main {
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		BigInteger f[]=new BigInteger[505];
    		f[0]=BigInteger.valueOf(1);
    		f[1]=BigInteger.valueOf(2);
    		for(int i=2;i<502;i++){
    			f[i]=f[i-1].add(f[i-2]);
    		}
    		while(true){
    			BigInteger a=input.nextBigInteger();
    			BigInteger b=input.nextBigInteger();
    			if(a.equals(BigInteger.ZERO)&&b.equals(BigInteger.ZERO))
    				break;
    			int sum=0;
    			for(int i=0;i<502&&b.compareTo(f[i])>=0;i++){
    				if(f[i].compareTo(a)>=0)
    					sum++;
    			}
    			System.out.println(sum);
    		}
    	}
    }


  • 相关阅读:
    Junit单元测试
    Stream流方法引用
    Stream流思想和常用方法
    算法
    函数式接口
    Zookeeper理解
    GreenPlum学习之(Share-nothing)架构
    链表反转问题
    KMP算法的java实现
    KMP详解之二
  • 原文地址:https://www.cnblogs.com/pangblog/p/3253500.html
Copyright © 2011-2022 走看看