zoukankan      html  css  js  c++  java
  • 2011年浙大:Graduate Admission

    题目描述:

        It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
        Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

        • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
        • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
        • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
        • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

    输入:

        Each input file may contain more than one test case.
        Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
        In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
        Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

    输出:

        For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

    样例输入:
    11 6 3
    2 1 2 2 2 3
    100 100 0 1 2
    60 60 2 3 5
    100 90 0 3 4
    90 100 1 2 0
    90 90 5 1 3
    80 90 1 0 2
    80 80 0 1 2
    80 80 0 1 2
    80 70 1 3 2
    70 80 1 2 3
    100 100 0 2 4
    样例输出:
    0 10
    3
    5 6 7
    2 8
    
    1 4

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <vector>
    using namespace std;
    struct Student{
        int ID;
        int GE,GI;
        double avg;
        int rnk;
        int choice[10];
    }stu[40005];
    int n,m,k;
    int quota[105];
    int tot;
    vector<int> sch[105];
    vector<int> ranked[40005];
    bool tag[105];
    bool vis[40005];
    bool comp(Student stu1,Student stu2)
    {
        if(stu1.avg!=stu2.avg)    return stu1.avg > stu2.avg;
        else    return stu1.GE > stu2.GE;
    }
    bool comp2(Student stu1,Student stu2)
    {
        return stu1.ID < stu2.ID;
    }
    int main()
    {
        while(cin>>n>>m>>k)
        {
            tot=0;
            for(int i=0;i<n;i++)    ranked[i].clear();
            for(int i=0;i<m;i++)    sch[i].clear();
            memset(quota,0,sizeof(quota));
            memset(vis,0,sizeof(vis));
            for(int i=0;i<m;i++)
            {
                cin>>quota[i];
            }
            for(int i=0;i<n;i++)
            {
                stu[i].ID=i;
                cin>>stu[i].GE>>stu[i].GI;
                stu[i].avg=(stu[i].GE+stu[i].GI)/2.0;
                for(int j=0;j<k;j++)
                {
                    cin>>stu[i].choice[j];
                }
            }
            sort(stu,stu+n,comp);
            stu[0].rnk=tot++;
            ranked[stu[0].rnk].push_back(stu[0].ID);
            for(int i=1;i<n;i++)
            {
                if(stu[i].avg!=stu[i-1].avg)
                {
                    stu[i].rnk=tot;
                }
                else if(stu[i].GE!=stu[i-1].GE)
                {
                    stu[i].rnk=tot;
                }
                else    stu[i].rnk=stu[i-1].rnk;
                tot++;
                ranked[stu[i].rnk].push_back(stu[i].ID);
            }
            sort(stu,stu+n,comp2);
            for(int i=0;i<tot;i++)
            {
                memset(tag,false,sizeof(tag));
                for(int j=0;j<ranked[i].size();j++)
                {
                    int id=ranked[i][j];
                    for(int z=0;z<k;z++)
                    {
                        if(vis[id])    break;
                        int type=stu[id].choice[z];
                        if(quota[type]>0||(quota[type]<=0&&tag[type]))
                        {
                            vis[id]=1;
                            sch[type].push_back(id);
                            quota[type]--;
                            if(quota[type]==0)    tag[type]=true;
                        }
                    }
                }
            }
            for(int i=0;i<m;i++)
            {
                if(sch[i].size()==0)    cout<<endl;
                else
                {
                    sort(sch[i].begin(),sch[i].end());
                    int size=sch[i].size();
                    for(int j=0;j<size-1;j++)
                    {
                        cout<<sch[i][j]<<" ";
                    }
                    cout<<sch[i][size-1]<<endl;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    Java序列化原理
    分库分表
    数据库索引
    监听TCP端口号:从简单Socket到NIO到Netty
    如何保证缓存与数据库的双写一致性
    代理模式:静态代理、JDK动态代理、Cglib动态代理
    Redis发布订阅(Pub-Sub)模式
    Redis分片机制(Sharding)
    Redis高可用性:主从、哨兵和集群
    Redis简介
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5827755.html
Copyright © 2011-2022 走看看