zoukankan      html  css  js  c++  java
  • poj 2431 Expedition 贪心+优先队列

    Expedition
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7707   Accepted: 2263

    Description

    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

    Input

    * Line 1: A single integer, N

    * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

    * Line N+2: Two space-separated integers, L and P

    Output

    * Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS:

    The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

    OUTPUT DETAILS:

    Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
     
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define maxn 100001
    const int inf=0x7fffffff;   //无限大
    int a[maxn];
    int b[maxn];
    int c[maxn];
    struct fox
    {
        int a;
        int b;
    };
    fox m[maxn];
    
    bool cmp(fox c,fox d)
    {
        return c.a<d.a;
    }
    int main()
    {
        int n;
        while(cin>>n){
        for(int i=0;i<n;i++)
        {
            cin>>m[i].a>>m[i].b;
        }
        int d,l;
        cin>>d>>l;
        for(int i=0;i<n;i++)
        {
            m[i].a=d-m[i].a;
        }
        sort(m,m+n,cmp);
        int pos=0;
        int flag=0;
        int ans=0;
        priority_queue<int> q;
        m[n].a=d;
        m[n].b=0;
        for(int i=0;i<=n;i++)
        {
            int dis=m[i].a-pos;
            if(dis>l)
            {
                while(1)
                {
                    if(q.empty())
                    {
                        flag=1;
                        break;
                    }
                    else
                    {
                        l+=q.top();
                        q.pop();
                        ans++;
                    }
                    if(l>=dis)
                        break;
                }
                if(flag==1)
                    break;
            }
            l-=dis;
            pos=m[i].a;
            q.push(m[i].b);
        }
        if(flag==1)
            cout<<"-1"<<endl;
        else
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    C#|.NET从控制反转(依赖注入)想到事件注入 (非AOP)
    libevent 2.1.3 for VS2008 source code
    如何进行object以及Array(数组)的深复制
    Flash ProgressEvent.bytesTotal为0的原因和解决
    Flash字体嵌入方法总结—(4)进阶篇
    mysql分组取每组前几条记录(排名) 附group by与order by的研究
    Flash游戏优化技巧
    教程:深入理解Flash的沙箱 – Application Domains
    Flash Player 11异步解码Bitmap
    常用公式
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4248688.html
Copyright © 2011-2022 走看看