zoukankan      html  css  js  c++  java
  • poj 2236 Wireless Network(并查集)

    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 14011   Accepted: 5941

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS
    import java.util.Scanner;
    
    public class Main{
    	private static F f[];
    	private static int n,d;
    	private static boolean vis[];
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		n=input.nextInt();
    		d=input.nextInt();
    		f=new F[n+1];
    		vis=new boolean[n+1];
    		//初始化
    		for(int i=1;i<=n;i++){
    			f[i]=new F(i);
    		}
    		//输入位置
    		for(int i=1;i<=n;i++){
    			int a=input.nextInt();
    			f[i].x=a;
    			int b=input.nextInt();
    			f[i].y=b;
    		}
    		while(input.hasNext()){
    			String s=input.next();
    			if('O'==s.charAt(0)){
    				int e=input.nextInt();
    				vis[e]=true;
    				for(int i=1;i<=n;i++){
    					if(vis[i]&&i!=e){
    						hebing(f[i],f[e]);//并查集合并集合
    					}
    				}
    			}
    			else{
    				int a=input.nextInt();
    				int b=input.nextInt();
    				if(find(a)==find(b)){
    					System.out.println("SUCCESS");
    				}
    				else
    					System.out.println("FAIL");
    			}
    		}
    		
    	}
    	private static void hebing(F f2, F f3) {
    		int x1=find(f2.poin);
    		int y1=find(f3.poin);
    		if(x1!=y1)
    			if((f2.x-f3.x)*(f2.x-f3.x)+(f2.y-f3.y)*(f2.y-f3.y)<=d*d){
    				f[x1].poin=y1;
    			}
    		
    	}
    	private static int find(int poin) {
    		while(poin!=f[poin].poin){
    			poin=f[poin].poin;
    		}
    		return poin;
    	}
    }
    class F{
    	int poin=0;
    	int x,y;
    	F(int poin){
    		this.poin=poin;
    		this.x=0;
    		this.y=0;
    	}
    }



  • 相关阅读:
    DoTween插件的使用
    Unity3D协程的简单使用
    排序和双指针,减小时间复杂度
    Unity3D自定义菜单组件
    滑动窗口思路分析
    Unity3D中的序列化特性和DLL特性
    求数组的交集,以及贪心算法的使用
    随笔开始啦
    实例26 循环体的过滤器
    实例25 终止循环体
  • 原文地址:https://www.cnblogs.com/riskyer/p/3243776.html
Copyright © 2011-2022 走看看