zoukankan      html  css  js  c++  java
  • SCOI2003 严格N元树

    SCOI2003 严格N元树

    Description


      如果一棵树的所有非叶节点都恰好有n个儿子,那么我们称它为严格n元树。如果该树中最底层的节点深度为d
    (根的深度为0),那么我们称它为一棵深度为d的严格n元树。例如,深度为2的严格2元树有三个,如下图:

    img

      给出n, d,编程数出深度为d的n元树数目。

    Input


      仅包含两个整数n, d( 0 < n < = 32, 0 < = d < = 16)

    Output


      仅包含一个数,即深度为d的n元树的数目。

    Sample Input


    【样例输入1】
    2 2
    【样例输入2】
    2 3
    【样例输入3】
    3 5

    Sample Output


    【样例输出1】
    3
    【样例输出2】
    21
    【样例输出2】
    58871587162270592645034001

    Solution


    懒得打高精板子,抄了一下AK爷的,感觉比我的好2333

    对于一个n元树,由教浅的树递推上来,因为每次加一层,都需要考虑深度不超过i-1的n元树的个数,把深度不超过i-1的乘起来,最后输出深度不超过d的减去深度不超过d-1的就是深度为d的n元树个数。

    Code


    //Writer : Hsz %WJMZBMR%tourist%hzwer
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cmath>
    #include<queue>
    #include<map>
    #include<set>
    #include<stack>
    #include<vector>
    #include<cstdlib>
    #include<algorithm>
    #define LL long long
    using namespace std;
    const int maxn=1005;
    struct bign{
        int d[maxn], len;
    
        void clean() { while(len > 1 && !d[len-1]) len--; }
    
        bign()          { memset(d, 0, sizeof(d)); len = 1; }
        bign(int num)   { *this = num; } 
        bign(char* num) { *this = num; }
        bign operator = (const char* num){
            memset(d, 0, sizeof(d)); len = strlen(num);
            for(int i = 0; i < len; i++) d[i] = num[len-1-i] - '0';
            clean();
            return *this;
        }
        bign operator = (int num){
            char s[2000]; sprintf(s, "%d", num);
            *this = s;
            return *this;
        }
    
        bign operator + (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] += b.d[i];
                if (c.d[i] > 9) c.d[i]%=10, c.d[i+1]++;
            }
            while (c.d[i] > 9) c.d[i++]%=10, c.d[i]++;
            c.len = max(len, b.len);
            if (c.d[i] && c.len <= i) c.len = i+1;
            return c;
        }
        bign operator - (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] -= b.d[i];
                if (c.d[i] < 0) c.d[i]+=10, c.d[i+1]--;
            }
            while (c.d[i] < 0) c.d[i++]+=10, c.d[i]--;
            c.clean();
            return c;
        }
        bign operator * (const bign& b)const{
            int i, j; bign c; c.len = len + b.len; 
            for(j = 0; j < b.len; j++) for(i = 0; i < len; i++) 
                c.d[i+j] += d[i] * b.d[j];
            for(i = 0; i < c.len-1; i++)
                c.d[i+1] += c.d[i]/10, c.d[i] %= 10;
            c.clean();
            return c;
        }
        bign operator / (const bign& b){
            int i, j;
            bign c = *this, a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                c.d[i] = j;
                a = a - b*j;
            }
            c.clean();
            return c;
        }
        bign operator % (const bign& b){
            int i, j;
            bign a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                a = a - b*j;
            }
            return a;
        }
        bign operator += (const bign& b){
            *this = *this + b;
            return *this;
        }
    
        bool operator <(const bign& b) const{
            if(len != b.len) return len < b.len;
            for(int i = len-1; i >= 0; i--)
                if(d[i] != b.d[i]) return d[i] < b.d[i];
            return false;
        }
        bool operator >(const bign& b) const{return b < *this;}
        bool operator<=(const bign& b) const{return !(b < *this);}
        bool operator>=(const bign& b) const{return !(*this < b);}
        bool operator!=(const bign& b) const{return b < *this || *this < b;}
        bool operator==(const bign& b) const{return !(b < *this) && !(b > *this);}
    
        string str() const{
            char s[maxn]={};
            for(int i = 0; i < len; i++) s[len-1-i] = d[i]+'0';
            return s;
        }
    };
    istream& operator >> (istream& in, bign& x)
    {
        string s;
        in >> s;
        x = s.c_str();
        return in;
    }
    
    ostream& operator << (ostream& out, const bign& x)
    {
        out << x.str();
        return out;
    }
    bign f[35];
    int n,d;
    int main() {
    	scanf("%d%d",&n,&d);
    	if(d==1&&n==1) return !printf("0");
    	if(d==0) return !printf("1");
    	f[1]=1;
    	for(int i=1;i<=d;i++){
    		bign tp=1;
    		for(int j=1;j<=n;j++) tp=tp*f[i-1];
    		f[i]=f[i]+tp+1;
    	}
    	cout<<f[d]-f[d-1];
    	return 0;
    }
    
    
    我是咸鱼。转载博客请征得博主同意Orz
  • 相关阅读:
    Docker 容器知识点
    Docker 常用命令
    杜教筛
    后缀自动机相关
    期望DP
    从零开始的莫比乌斯反演(函数)[详细推导]
    欧拉函数|(扩展)欧拉定理|欧拉反演
    优美诗词(持续更新)
    魔法 [线段树优化DP]
    stone2 [期望]
  • 原文地址:https://www.cnblogs.com/sdfzhsz/p/9135326.html
Copyright © 2011-2022 走看看