zoukankan      html  css  js  c++  java
  • Robot Motion

     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 11269   Accepted: 5486

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

    N north (up the page) 
    S south (down the page) 
    E east (to the right on the page) 
    W west (to the left on the page) 

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)
    #include <iostream>
    #include<string.h>
    using namespace std;
    
    int main() {
        int row,col,x,y;
    
        int pos[10][10];
        char ins[10][10];
        int step;
        int flag=-1;
        cin>>row>>col>>x;
        while(row&&col&&x){
            memset(pos,0,sizeof(int)*100);
            y=1;
            step=1;
            flag=-1;
            for(int i=0;i<row;i++){
                for(int j=0;j<col;j++){
                    cin>>ins[i][j];
                }
            }
            pos[y-1][x-1]=1;
            for(int i=0;i<row*col;i++){
                switch(ins[y-1][x-1]){
                case 'N':
                    y--;
                    break;
                case 'E':
                    x++;
                    break;
                case 'S':
                    y++;
                    break;
                case 'W':
                    x--;
                    break;
                }
    
                if(y>row||y<1||x>col||x<1){
                    flag=0;
                    break;
                }else if(pos[y-1][x-1]!=0){
                    flag=1;
                    break;
                }else{
                    ++step;
                    pos[y-1][x-1]=step;
                }
    
            }
            if(flag==0){
                cout<<step<<" step(s) to exit"<<endl;
            }else{
                cout<<(pos[y-1][x-1]-1)<<" step(s) before a loop of "<<(step-pos[y-1][x-1]+1)<<" step(s)"<<endl;
            }
            cin>>row>>col>>x;
        }
        return 0;
    }
  • 相关阅读:
    JavaScript之闭包
    JavaScript之原型模式
    .NET Core3.1 解决跨域问题 Startup的配置
    .NTE Core 使用Editor.md富文本编辑器上传图片
    .NET Core3.1 WebApi 配置Swagger 超详细办法
    C#添加写日志,记录单个变量
    一个让我痛不欲生的算法题
    用EF 搭建底层
    用Linq To SQL 搭建底层
    安卓端腾讯QQ-【我的电脑】下载地址
  • 原文地址:https://www.cnblogs.com/sdxk/p/4621841.html
Copyright © 2011-2022 走看看