zoukankan      html  css  js  c++  java
  • nyoj 72 399

    Financial Management
    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
    描述
    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough.

     Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first
     
     step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how
     
      much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and
     
       calculate his average account balance.
    输入
    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month.

     Each number will be positive and displayed to the penny. No dollar sign will be included.

    输出
    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded

    to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces
     or characters in the output.

    样例输入
    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75
    样例输出
    1581.42来源
    [张洁烽]原创
    上传者
    张洁烽

    #include "stdio.h"
    int main()
    {   int i;
        double a[13],sum=0;
     for(i=0;i<12;i++)
     {scanf("%lf",&a[i]);
       sum+=a[i];
    }
     printf("%.2lf ",sum/12);
    return 0;
    }

    整除个数
    时间限制:3000 ms  |  内存限制:65535 KB
    难度:1
    描述
    1、2、3… …n这n(0<n<=1000000000)个数中有多少个数可以被正整数b整除。
    输入
    输入包含多组数据
    每组数据占一行,每行给出两个正整数n、b。
    输出
    输出每组数据相应的结果。
    样例输入
    2 1
    5 3
    10 4
    样例输出
    2
    1
    2
    来源
    自编
    上传者
    mix_math

    思路:这充分利用了计算机中除法的运算
    /*#include "stdio.h"

    int main()
    {  int n,b;
        int i,j;
      while(scanf("%d%d",&n,&b)!=EOF)
        { 
            j=0;
            if(b==1)
          printf("%d ",n);
          else
          printf("%d ",n/b);
      }
      return 0;
    }
    */
    #include "stdio.h"

    int main()
    {  int n,b;
        int i,j;
      while(scanf("%d%d",&n,&b)!=EOF)
        { 
       
          printf("%d ",n/b);
      }
      return 0;
    }

  • 相关阅读:
    MyEclipse for Spring 10.0: GWT 2.1 and Spring Scaffolding
    redis 协议
    Eclipse项目编译
    urlencode
    Firefox浏览器设置字符编码格式
    怎么从一台电脑的浏览器输入地址访问另一台电脑服务器(WAMP服务器已搭建,PHPSTORM装好了)...
    Tplink路由器怎么设置端口映射 内网端口映射听语音
    5.04 toArray()有一个问题须要解决一下
    WCF服务编程读书笔记(4):实例管理
    maven常用命令介绍
  • 原文地址:https://www.cnblogs.com/songmingtao/p/3243950.html
Copyright © 2011-2022 走看看