zoukankan      html  css  js  c++  java
  • HDU 1065.I Think I Need a Houseboat

    I Think I Need a Houseboat

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 27   Accepted Submission(s) : 11

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description



    Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

    After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 

    Input

    The first line of input will be a positive integer indicating how many data sets will be included (N). 

    Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

    Output

    For each data set, a single line of output should appear. This line should take the form of: 

    “Property N: This property will begin eroding in year Z.” 

    Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. 

    After the last data set, this should print out “END OF OUTPUT.” 

    Notes: 

    1. No property will appear exactly on the semicircle boundary: it will either be inside or outside. 

    2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines. 

    3. All locations are given in miles.

    Sample Input

    2 
    1.0 1.0 
    25.0 0.0
    

    Sample Output

    Property 1: This property will begin eroding in year 1. 
    Property 2: This property will begin eroding in year 20. 
    END OF OUTPUT. 
    

    Source

    Mid-Atlantic USA 2001
    #include <iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    using namespace std;
    int n,t;
    double s,x,y,year;
    int main()
    {
        scanf("%d",&n);
        for(int t=1;t<=n;t++)
        {
            s=1.0;
            scanf("%lf%lf",&x,&y);
            s=3.1415926*(x*x+y*y)/2;
            printf("Property %d: ",t);
            printf("This property will begin eroding in year %d.\n",(int)(s/50)+1);// 注意计算方法
        }
        printf("END OF OUTPUT.\n");
        return 0;
    }
  • 相关阅读:
    C#过滤重复数据,使用泛型
    office2007:您正试图运行的函数包含有宏或需要宏语言支持的内容。而在安装此软件时,您(或您的管理员)选择了不安装宏或控件的支持功能
    InstallShield高级应用获取本机所有的SQL服务
    结对项目
    ActiveMQ 初学1:ActiveMQ 创建连接对象
    【JVM】jstack和dump线程分析(2)
    【JVM】jstack 查询占用最大资源线程|排查死循环等
    【java多线程】volatile 关键字
    1.zookeeper原理解析数据存储之Zookeeper内存结构
    【数据算法】Java实现二叉树存储以及遍历
  • 原文地址:https://www.cnblogs.com/stepping/p/5648427.html
Copyright © 2011-2022 走看看