zoukankan      html  css  js  c++  java
  • Basically Speaking

    Basically Speaking

     

    Time Limit: 2 Sec  Memory Limit: 200 MB

    Submit: 19  Solved: 11

    [Submit][Status][Web Board]

    Description

    The Really Neato Calculator Company, Inc. has recently hired your team to help design

     their Super Neato Model I calculator. As a computer scientist you suggested to the

    company that it would be neato if this new calculator could convert among number bases.

     The company thought this was a stupendous idea and has asked your team to come up

     with the prototype program for doing base conversion. The project manager of the Super

     Neato Model I calculator has informed you that the calculator will have the following neato features:

    It will have a 7-digit display.

    Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

    It will support bases 2 through 16.

    Input

    The input for your prototype program will consist of one base conversion per line.

    There will be three numbers per line. The first number will be the number in the

    base you are converting from. The second number is the base you are converting from.

     The third number is the base you are converting to. There will be one or more blanks

     surrounding (on either side of) the numbers. There are several lines of input and your

    program should continue to read until the end of file is reached.

    Output

    The output will only be the converted number as it would appear on the display of the

    calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display,

    then print ``ERROR'' (without the quotes) right justified in the display.

    Sample Input

    1111000 2 10

    1111000 2 16

    2102101  3 10

    2102101 3   15

    12312 4   2

    1A   15 2

    1234567 10 16

    ABCD 16 15

    Sample Output

        120

         78

       1765

        7CA

      ERROR

      11001

     12D687

       D071

    #include <iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int a,b,l,i;
    long long sum;
    char ch[10];
    int work(char ch)
    {
        if(ch>='0' && ch<='9') return ch-'0';
         return ch-'A'+10;
    }
    char solve(int k)
    {
        if (k<10) return char(k+48);
          return char(k+55);
    }
    int main()
    {
        while(~scanf("%s%d%d",&ch,&a,&b))
        {
            l=strlen(ch);
            sum=0;
            for(int i=0;i<l;i++)
                sum=sum*a+work(ch[i]);
            if (sum==0)
            {
                printf("      0\n");
                continue;
            }
            l=0;
            while(sum>0)
            {
                ch[++l]=solve(sum%b);
                sum=sum/b;
            }
           if (l<=7)
            {
                for(i=1;i<=7-l;i++) printf(" ");
                for(i=l;i>=1;i--) printf("%c",ch[i]);
            }
            else printf("  ERROR");
           printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    ios开发-2015-08-07
    ios开发-2015-08-06
    ios开发-2015-08-04
    ios开发-2015-08-03
    ios开发-2015-08-02
    Selenium学习笔记之013:控制滚动条到底部 分类: Selenium 2015-07-23 00:26 19人阅读 评论(0) 收藏
    Selenium学习笔记之012:处理下拉框 分类: Selenium 2015-07-23 00:15 19人阅读 评论(0) 收藏
    Selenium学习笔记之012:处理下拉框
    Selenium学习笔记之011:操作对象 分类: Selenium 2015-07-22 23:33 15人阅读 评论(0) 收藏
    Selenium学习笔记之011:操作对象
  • 原文地址:https://www.cnblogs.com/stepping/p/5683086.html
Copyright © 2011-2022 走看看