zoukankan      html  css  js  c++  java
  • hdu 3342 Legal or Not(拓扑排序)

    Legal or Not

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 42   Accepted Submission(s) : 32

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

    Input

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
    TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

    Output

    For each test case, print in one line the judgement of the messy relationship.
    If it is legal, output "YES", otherwise "NO".

    Sample Input

    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0

    Sample Output

    YES
    NO
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<vector>
    #include<queue>
    using namespace std;
    int i,n,m;
    int cnt[505];
    vector<int> s[505];
    
    bool toposort()
    {
        queue<int> Q;
        int num=0;
        for(int i=0;i<n;i++) if (cnt[i]==0) Q.push(i);
        if(Q.empty()) return 0;
        while(!Q.empty())
        {
            int u=Q.front();
            Q.pop();
            num++;
            for(int i=0;i<s[u].size();i++)
            {
                cnt[s[u][i]]--;
                if (cnt[s[u][i]]<0) return 0;
                if (cnt[s[u][i]]==0) Q.push(s[u][i]);
            }
        }
        if (num<n) return 0;
        return 1;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m))
        {
            if (n==0 && m==0) break;
            memset(cnt,0,sizeof(cnt));
            for(i=0;i<n;i++) s[i].clear();
            for(i=1;i<=m;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                s[x].push_back(y);
                cnt[y]++;
            }
            if (toposort()) printf("YES\n");
                    else printf("NO\n");
        }
        return 0;
    }
  • 相关阅读:
    巧用SQL Server Profiler
    Linq结果直接返回实体对象
    C#(MVC) Word 替换,填充表格,导出并下载PDF文档
    C#匿名类型(Anonymous Type)学习日记
    C#Lambda表达式学习日记
    C#事件(Event)学习日记
    C#委托(Delegate)学习日记
    C#隐私信息(银行账户,身份证号码,名字)中间部分特殊字符替换(*)
    CSS布局模型
    Visual Studio 内置快速生产代码简写集合
  • 原文地址:https://www.cnblogs.com/stepping/p/5704492.html
Copyright © 2011-2022 走看看