zoukankan      html  css  js  c++  java
  • uva 242

    242 - Stamps and Envelope Size

    Time limit: 3.000 seconds

     Stamps and Envelope Size 

    Philatelists have collected stamps since long before postal workers were disgruntled. An excess of stamps may be bad news to a country's postal service, but good news to those that collect the excess stamps. The postal service works to minimize the number of stamps needed to provide seamless postage coverage. To this end you have been asked to write a program to assist the postal service.

    Envelope size restricts the number of stamps that can be used on one envelope. For example, if 1 cent and 3 cent stamps are available and an envelope can accommodate 5 stamps, all postage from 1 to 13 cents can be ``covered":

    tabular21

    Although five 3 cent stamps yields an envelope with 15 cents postage, it is not possible to cover an envelope with 14 cents of stamps using at most five 1 and 3 cent stamps. Since the postal service wants maximal coverage without gaps, the maximal coverage is 13 cents.

    Input

    The first line of each data set contains the integer S, representing the maximum of stamps that an envelope can accommodate. The second line contains the integer N, representing the number of sets of stamp denominations in the data set. Each of the next N lines contains a set of stamp denominations. The first integer on each line is the number of denominations in the set, followed by a list of stamp denominations, in order from smallest to largest, with each denomination separated from the others by one or more spaces. There will be at most S denominations on each of the N lines. The maximum value of S is 10, the largest stamp denomination is 100, the maximum value of N is 10.

    The input is terminated by a data set beginning with zero (S is zero).

    Output

    Output one line for each data set giving the maximal no-gap coverage followed by the stamp denominations that yield that coverage in the following format:

    max coverage = <value> : <denominations>

    If more than one set of denominations in a set yields the same maximal no-gap coverage, the set with the fewest number of denominations should be printed (this saves on stamp printing costs). If two sets with the same number of denominations yield the same maximal no-gap coverage, then the set with the lower maximum stamp denomination should be printed. For example, if five stamps fit on an envelope, then stamp sets of 1, 4, 12, 21 and 1, 5, 12, 28 both yield maximal no-gap coverage of 71 cents. The first set would be printed because both sets have the same number of denominations but the first set's largest denomination (21) is lower than that of the second set (28). If multiple sets in a sequence yield the same maximal no-gap coverage, have the same number of denominations, and have equal largest denominations, then print the set with the lewer second-maximum stamp denomination, and so on.

    Sample Input

    5
    2
    4 1 4 12 21
    4 1 5 12 28
    10
    2
    5 1 7 16 31 88
    5 1 15 52 67 99
    6
    2
    3 1 5 8
    4 1 5 7 8
    0

    Sample Output

    max coverage = 71 : 1 4 12 21 max coverage = 409 : 1 7 16 31 88 max coverage = 48 : 1 5 7 8

    记忆化搜索
    一开始读错题了,以至于想得非常复杂,后来终于读明白了,比较简单的记搜。
    d[i][j]表示用i张邮票凑成邮资j。
    注意输出的格式。反正我是pe了。

    #include <cstdio>
    #include <iostream>
    #include <sstream>
    #include <cmath>
    #include <cstring>
    #include <cstdlib>
    #include <string>
    #include <vector>
    #include <map>
    #include <set>
    #include <queue>
    #include <stack>
    #include <algorithm>
    using namespace std;
    #define ll long long
    #define _cle(m, a) memset(m, a, sizeof(m))
    #define repu(i, a, b) for(int i = a; i < b; i++)
    #define MAXN 1001
    int d[11][MAXN];
    int s1[11], s2[11];
    int s, n;
    
    int Judge()
    {
        for(int i = s1[0]; i > 0; i--)
            if(s1[i] < s2[i]) return true;
            else if(s1[i] < s2[i]) ;
            else return false;
        return false;
    }
    
    int dp(int p, int q)
    {
        if(p > s) return 0;
        if(d[p][q] != -1) return d[p][q];
        for(int i = s1[0]; i > 0; i--)
            dp(p + 1, q + s1[i]);
        d[p][q] = 1;
    }
    
    int get_max()
    {
        int flag;
        for(int i = 1; ; i++)
        {
            flag = 0;
            for(int j = 1; j <= s; j++)
                if(d[j][i] == 1) flag = 1;
            if(!flag) return i - 1;
        }
    }
    
    void put()
    {
        repu(i, 0, s2[0] + 1) printf("%d ", s2[i]);
        puts("");
    }
    int main()
    {
        while(~scanf("%d", &s) && s)
        {
            scanf("%d",&n);
            int maxn = 0;
            repu(i, 0, n)
            {
                _cle(d, -1);
                scanf("%d", &s1[0]);
                repu(j, 1, s1[0] + 1) scanf("%d", &s1[j]);
                dp(0, 0);
                int t = get_max();
                if(i == 0)
                {
                    memcpy(s2, s1, sizeof(s1));
                    maxn = t;
                }
                else if(maxn == t)
                {
                    if(s1[0] < s2[0] || (s1[0] == s2[0] && Judge()))
                    {
                        memcpy(s2, s1, sizeof(s1));
                    }
                }
                else if(maxn < t)
                {
                    memcpy(s2, s1, sizeof(s1));
                    maxn = t;
                }
            }
            printf("max coverage = %3d :", maxn);
            repu(i, 1, s2[0] + 1) printf(" %2d", s2[i]);
            puts("");
        }
        return 0;
    }
    View Code
  • 相关阅读:
    jquery选择器
    js中的闭包技术
    idea创建servlet不能创建:
    JSP页面不解析EL表达式的原因
    大对象数据LoB的应用
    缓冲流、转换流、序列化流相关流知识点
    jdk5.0新特性(注解)
    EKT相关知识(Class类对象的方法补充)
    java中调用存储过程或函数
    Java 缓冲流
  • 原文地址:https://www.cnblogs.com/sunus/p/4507393.html
Copyright © 2011-2022 走看看