zoukankan      html  css  js  c++  java
  • soj1001. Alphacode

    1001. Alphacode

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

    Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

    Input

    Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

    Output

    For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

    Sample Input

    25114
    1111111111
    3333333333
    0
    

    Sample Output

    6
    89
    1

    比较简单的动态规划,值得注意的是qq[i] == '0'的情况(我一开始也没有注意到,WA了几遍,给跪了)。
    //很简单的动态规划
    #include <iostream>
    #include <string>
    #include <vector>
    using namespace std;
    int main()
    {
    	string ss;
    	while(cin >> ss && ss != "0")
    	{
    		vector<long> qq;
    		int len = ss.length();
    		qq.resize(len+1);
    		int i;
    		qq[0] = 1;
    		qq[1] = 1;
    		for(i = 1;i < ss.size();i++)
    		{
    			if(ss[i] == '0')
    				qq[i+1] = qq[i-1];
    			else if((ss[i] >= '1' && ss[i] <= '9' && ss[i-1] == '1')||(ss[i] >= '1' && ss[i] <= '6' && ss[i-1] == '2'))
    				qq[i+1] = qq[i] + qq[i-1];
    			else 
    				qq[i+1] = qq[i];
    		}
    		cout << qq[len] << endl;
    	}
    	return 0;
    }
    

  • 相关阅读:
    线程进程之间的关系
    socket网络编程
    Docker在github上的站点
    大型网站架构体系的演变
    centos7 安装SSH
    如何在CentOS 7中禁用IPv6
    在 Docker 上运行一个 RESTful 风格的微服务
    docker 操作命令详解
    玩转Docker镜像
    搭建自己的 Docker 私有仓库服务
  • 原文地址:https://www.cnblogs.com/sysu-blackbear/p/3199740.html
Copyright © 2011-2022 走看看