zoukankan      html  css  js  c++  java
  • HDU1074-Doing Homework

    Doing Homework

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4366    Accepted Submission(s): 1763

    Problem Description
    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).
    Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
     
    Output
    For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
     
    Sample Input
    2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
     
    Sample Output
    2 Computer Math English 3 Computer English Math
    Hint
    In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
     
    Author
    Ignatius.L
     
     
    第二道状态压缩DP,一开始卡在状态描述上,不知道从哪下手,后来看了别人的代码才明白,其实这道状态DP真的很简单啊。。。
     
    #include<stdio.h>
    #include<string.h>
    struct node
    {
     char name[25];
     int dt;
     int ct;
    }s[25];
    struct node1
    {
     int now;
     int pre;
     int mintime;
    }dp[1<<16];
    int visit[1<<16];
    void print_name(int k,int t)
    {
     int count = 0,temp;
     temp = k^t;
     while(temp)
     {
      temp = (temp>>1);
      count++;
     }
     k = t;
     t = dp[t].pre;
     if(t != -1)
     {
      print_name(k,t);
     }
     printf("%s ",s[count-1].name);
    }
    int main()
    {
     int t,n,i,j;
     scanf("%d",&t);
     while(t--)
     {
      scanf("%d",&n);
      for(i=0;i<n;i++)
      {
       scanf("%s%d%d",s[i].name,&s[i].dt,&s[i].ct);
      }
      memset(visit,0,sizeof(visit));
      int a,b,c,d;
      dp[0].pre = -1;
      dp[0].now = 0;
      dp[0].mintime = 0;
      for(i=0;i<(1<<n)-1;i++)
      {
       for(j=0;j<n;j++)
       {
        int temp = (1<<j);
        a = (temp & i);
        if(a == 0)
        {
         b = (temp | i);
         c = dp[i].now+s[j].ct-s[j].dt;
         if(c < 0) c=0;
         d = dp[i].mintime + c;
         if(visit[b])
         {
          if(d < dp[b].mintime)
          {
           dp[b].mintime = d;
           dp[b].pre = i;
           dp[b].now = dp[i].now + s[j].ct;
          }
         }
         else
         {
          visit[b] = 1;
          dp[b].mintime = d;
          dp[b].pre = i;
          dp[b].now = dp[i].now + s[j].ct;
         }
        }
       }
      }
      printf("%d ",dp[(1<<n)-1].mintime);
      print_name( (1<<n) - 1, dp[(1<<n)-1].pre);
     }
     return 0;
    }
  • 相关阅读:
    Update SSM agent to each EC2 via Bat and bash script
    Shell脚本循环读取文件中的每一行
    通过psexec实现远程安装软件包
    Getting Private/Public IP address of EC2 instance using AWS-cli [closed]
    Python to list users in AWS
    BAT script to set local account password never expire
    Difference between Netbios and Host name
    PowerShell官方文档
    powershell for rename server name
    Create a conditional DNS forwarder on our domain.com to Amazon default DNS provider
  • 原文地址:https://www.cnblogs.com/tengtao93/p/3448523.html
Copyright © 2011-2022 走看看