zoukankan      html  css  js  c++  java
  • UVALive2356 ZOJ1061 Web Navigation【堆栈+模拟】

    Web Navigation

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.

    The following commands need to be supported:

    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

    VISIT <url>: Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

    QUIT: Quit the browser.

    Assume that the browser initially loads the web page at the URL http://www.acm.org/


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.


    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    1

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored


    Source: East Central North America 2001



    Regionals 2001 >> North America - East Central NA


    问题链接UVALive2356 ZOJ1061 Web Navigation

    题意简述:(略)

    问题分析这个是有关浏览器操作的问题,直接模拟。

    程序说明:需要使用两个堆栈存储访问履历,以备操作使用。使用堆栈是因为操作过程与堆栈是相似的。


    AC的C++语言程序如下:

    /* UVALive2356 ZOJ1061 Web Navigation */
    
    #include <iostream>
    #include <string>
    #include <stack>
    
    using namespace std;
    
    int main()
    {
        int n;
    
        cin >> n;
        while(n--) {
            stack<string> ss, st;
            string cmd, url;
    
            ss.push("http://www.acm.org/");
    
            while(cin >> cmd) {
                if(cmd[0] == 'Q')           // QUIT
                    break;
                else if(cmd[0] == 'V') {     // VISIT
                    cin >> url;
                    ss.push(url);
                    cout << url << endl;
    
                    // 清空:一旦输入一个新的URL,就不能再做FORWARD了
                    while(!st.empty())
                        st.pop();
                } else if(cmd[0] == 'B') {  // BACK
                    if(ss.size() > 1) {
                        st.push(ss.top());
                        ss.pop();
                        cout << ss.top() << endl;
                    } else
                        cout << "Ignored" << endl;
                } else if(cmd[0] == 'F') {  // FORWARD
                    if(!st.empty()) {
                        ss.push(st.top());
                        cout << st.top() << endl;
                        st.pop();
                    } else
                        cout << "Ignored" << endl;
                }
            }
    
            if(n)
                cout << endl;
        }
    
        return 0;
    }




  • 相关阅读:
    Java 写GBK 、utf8格式的文件 java
    NIOnio的美文分享一下,最近喜欢上了Nio希望能给大家扫扫盲
    maven入门和进阶 基础入门 希望帮助大家maven 教程
    log4j 基础
    FastDFS架构剖析(非常值得一看的架构分析和解读)
    FastDFS分布式文件系统问题总汇
    oracle 建表创建外键
    Mybatis下log4j日志输出不正常的解决办法 ,很实用哦 !!!!
    httpclient入门例子 demos
    Firebug http请求响应时间线
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563697.html
Copyright © 2011-2022 走看看