zoukankan      html  css  js  c++  java
  • 1054 The Dominant Color (20)(20 分)

    Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, simply print the dominant color in a line.

    Sample Input:

    5 3
    0 0 255 16777215 24
    24 24 0 0 24
    24 0 24 24 24
    

    Sample Output:

    24
    #include<cstdio>
    int main(){
        int m,n,col,ans= -1,count = 0;
        scanf("%d%d",&m,&n);
        for(int i = 0; i < m; i++){
            for(int i = 0; i < n; i++){
                scanf("%d",&col);
                if(count == 0){
                    ans = col;
                    count = 1;
                }
                else{
                    if(ans  == col) count++;
                    else count--;
                }
            }
        }
        printf("%d",ans);
        return 0;
    }
    #include<cstdio>
    #include<map>
    using namespace std;
    int main(){
        int n,m,col;
        map<int,int> count;
        scanf("%d%d",&m,&n);
        for(int i = 0; i < m; i++){
            for(int j= 0; j < n; j++){
                scanf("%d",&col);
                if(count.find(col)!=count.end()) count[col]++;
                else count[col] = 1;
            }
        }
        int k = 0, max = 0;
        for(map<int,int>::iterator it=count.begin(); it != count.end(); it++){
            if(it -> second  > max){
                k = it -> first;
                max = it -> second;
            }
        }
        printf("%d",k);
        return 0;
    }
  • 相关阅读:
    eclipse报错:发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素
    深入解析_Android的自定义布局
    RSA算法加密解密
    android版本
    TabHost+RadioGroup搭建基础布局
    android横竖屏控制
    一大波静态方法
    有时候
    简单的dialog菜单
    mongodb学习(三)——函数使用的小技巧
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9154847.html
Copyright © 2011-2022 走看看