zoukankan      html  css  js  c++  java
  • HDOJ 1048 The Hardest Problem Ever(加密解密类)

    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
    You are a sub captain of Caesar’s army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is ‘A’, the cipher text would be ‘F’). Since you are creating plain text out of Caesar’s messages, you will do the opposite:

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

    A single data set has 3 components:

    Start line - A single line, “START”

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

    End line - A single line, “END”

    Following the final data set will be a single line, “ENDOFINPUT”.

    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.

    Sample Input
    START
    NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
    END
    START
    N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
    END
    START
    IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
    END
    ENDOFINPUT

    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
    I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
    DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

    就是一个加密解密的过程;

    import java.util.Scanner;
    
    public class Main{
        static char[] ctext =new char[26];
        static char[] ptext =new char[26];
        public static void main(String[] args) {
            ctet();
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                String str = sc.nextLine();
                if(str.equals("ENDOFINPUT")){
                    break;
                }
                //System.out.println("str="+str);
                    String strs = sc.nextLine();
                //  System.out.println("strs="+strs);
                    for(int i=0;i<strs.length();i++){
                        if(strs.charAt(i)>='A'&&strs.charAt(i)<='Z'){
                            for(int j=0;j<ctext.length;j++){
                                if(strs.charAt(i)==ctext[j]){
                                    System.out.print(ptext[j]);
                                    break;
                                }
                            }
    
                        }else{
                            System.out.print(strs.charAt(i));
                        }
    
                    }
                    System.out.println();
    //              String a = sc.nextLine();
    //              System.out.println("a = "+a);
                String s = sc.nextLine();
                //System.out.println("s = "+s);
    
    
            }
    
        }
        private static void ctet() {
            int k=0;
            for(int i='A';i<='Z';i++){
                ctext[k++]=(char)i;
            }
            String str = "V W X Y Z A B C D E F G H I J K L M N O P Q R S T U";
            String strs[] = str.split(" +");
            k=0;
            for(int i='A';i<='Z';i++){
                ptext[k] =strs[k].charAt(0);
                k++;
            }
        }
    
    }
  • 相关阅读:
    信息增益(Information Gain)(转)
    数据挖掘潜规则zz
    Google AdWords 广告排名首选项
    看图说话:关于BI那点事儿
    BI实施的四个层次
    10个有用的数据可视化资源
    数据可视化六步法
    数据仓库构建步骤
    关于javascript中对浮点加,减,乘,除的精度分析
    AMD规范与CMD规范的区别
  • 原文地址:https://www.cnblogs.com/webmen/p/5739349.html
Copyright © 2011-2022 走看看