zoukankan      html  css  js  c++  java
  • HDOJ 2056 Rectangles

    Problem Description
    Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

    Input
    Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

    Output
    Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

    Sample Input
    1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
    5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

    Sample Output
    1.00
    56.25

    题目大意:求两个矩形相交的面积,矩形的边均平行于坐标轴。

    
    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                double[] x = new double[4];
                double[] y = new double[4];
    
                for(int i=0;i<x.length;i++){
                    x[i] = sc.nextDouble();
                    y[i] = sc.nextDouble();
                }
    
                if(x[1]<x[0]){
                    double temp=x[0];
                    x[0]=x[1];
                    x[1]=temp;
                }
                if(y[1]<y[0]){
                    double temp=y[0];
                    y[0]=y[1];
                    y[1]=temp;
                }
    
                if(x[3]<x[2]){
                    double temp=x[3];
                    x[3]=x[2];
                    x[2]=temp;
                }
    
                if(y[3]<y[2]){
                    double temp=y[3];
                    y[3]=y[2];
                    y[2]=temp;
                }
    
    
                double x1 = max(x[0],x[2]);
                double y1 = max(y[0],y[2]);
                double x2 = min(x[1],x[3]);
                double y2 = min(y[1],y[3]);
    
                if(x1>x2||y1>y2){
                    System.out.println("0.00");
                    continue;
                }else{
                    System.out.printf("%.2f",(x2-x1)*(y2-y1));
                    System.out.println();
                }
    
    
            }
    
    
        }
    
        private static double min(double d, double e) {
            if(d<e){
                return d;
            }
            return e;
        }
    
        private static double max(double d, double e) {
            if(d>e){
                return d;
            }
            return e;
        }
    
    }
    
  • 相关阅读:
    Django-配置Mysql
    Django-manage.py shell命令
    Codeforces 1516B AGAGA XOOORRR
    sitemesh入门教程
    养生好习惯
    解决idea自动导入类String总是导入sun.org.apache.xpath.internal.operations包下的String
    [C#]浅谈协变与逆变
    [C#]跨模块的可选参数与常量注意事项
    [C#]LockBits使用笔记
    1.在校研究生申请软件著作权(学校为第一著作人)
  • 原文地址:https://www.cnblogs.com/webmen/p/5739430.html
Copyright © 2011-2022 走看看