zoukankan      html  css  js  c++  java
  • 1190: 零起点学算法97——A == B ?(Java)

    WUSTOJ 1190: 零起点学算法97——A == B ?

    Description

            Give you two integer numbers A and B, if A is equal to B, you should print “YES”, or print “NO”.

    Input

            each test case contains two integer numbers A and B.

    Output

            for each case, if A is equal to B, you should print “YES”, or print “NO”.

    Sample Input

    1 2
    2 2
    3 3
    4 3
    

    Sample Output

    NO
    YES
    YES
    NO
    

    HINT

            注意A、B数位最多100位。

    代码

    /**
     * 用时:472ms
     * @author wowpH
     * @version A1.1
     * @date 2019年4月13日 下午9:35:04
     */
    
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
    
    	private Scanner sc;
    	private BigInteger A, B;
    
    	public Main() {
    		sc = new Scanner(System.in);
    		while(sc.hasNext()) {
    			A = sc.nextBigInteger();
    			B = sc.nextBigInteger();
    			if(A.equals(B)) {
    				System.out.println("YES");
    			} else {
    				System.out.println("NO");
    			}
    		}
    		sc.close();
    	}
    
    	public static void main(String[] args) {
    		new Main();
    	}
    
    }
    

            我为什么没有早点发现这个大数类(BigInteger),这么好用的一个类。
            虽然上面代码是正确的的,但是我想知道为什么下面这个就不行呢?

    double 的表示范围是:1.7976931348623157e+308 这个为什么不行呢?

    /**
     * 提交:Wrong Answer
     * @author wowpH
     * @version A1.0
     * @date 2019年4月13日 下午9:35:04
     */
    
    import java.util.Scanner;
    
    public class Main {
    
    	private Scanner sc;
    	private double A, B;
    
    	public Main() {
    		sc = new Scanner(System.in);
    		while(sc.hasNext()) {
    			A = sc.nextDouble();
    			B = sc.nextDouble();
    			if(A == B) {
    				System.out.println("YES");
    			} else {
    				System.out.println("NO");
    			}
    		}
    		sc.close();
    	}
    
    	public static void main(String[] args) {
    		new Main();
    	}
    
    }
    
  • 相关阅读:
    STL与基础数据结构
    solr基础总结
    linux命令笔记
    SolrCloud集群部署
    oracle SQL笔记
    内存溢出之Tomcat内存配置
    solr查询优化(实践了一下效果比较明显)
    JAVA处理线程超时
    Solr 数据导入 <一>DIH简单使用
    几种防止表单重复提交的方法
  • 原文地址:https://www.cnblogs.com/wowpH/p/11060823.html
Copyright © 2011-2022 走看看