zoukankan      html  css  js  c++  java
  • HDU1222Wolf and Rabbit(GCD思维)

    Wolf and Rabbit

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9060    Accepted Submission(s): 4612


    Problem Description
    There is a hill with n holes around. The holes are signed from 0 to n-1.



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
     
    Input
    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
     
    Output
    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
     
    Sample Input
    2 1 2 2 2
     
    Sample Output
    NO YES
    /*************************************************************************
        > File Name: HDU1222.cpp
        > Author: LyuCheng
        > Created Time: 2017年10月18日 星期三 21时11分08秒
     ************************************************************************/
    /*
     * 题意:大灰狼追小白兔。小白兔可以躲起来的洞绕成一个圈,大灰狼从0这个点出发,
     *      每次走m个,问这些洞有木有可以不被狼找到的。
     * 思路:如果gcd(n,m)不等于1的话,那么最小公倍数不为n*m,那么用x(x<n)次,大灰
     *      狼就会跑到出发位置,肯定不会遍历n个点.
     * */
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int t;
    int a,b;
    
    int main(){
        scanf("%d",&t);
        while(t--){
                scanf("%d%d",&a,&b);
                if(__gcd(a,b)==1){
                        puts("NO");
                }else{
                        puts("YES");
                }
        }
        return 0;
    }
  • 相关阅读:
    函数之形参与实参
    函数的介绍与方法
    生活如戏
    zabbix中的sql
    1
    1
    通过snmpwalk抓取设备端口的流量状况
    abc
    as
    网络质量IP获取脚本
  • 原文地址:https://www.cnblogs.com/wuwangchuxin0924/p/7689044.html
Copyright © 2011-2022 走看看