zoukankan      html  css  js  c++  java
  • 高效算法——A 归并排序

    In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
    9 1 0 5 4 ,

    Ultra-QuickSort produces the output 
    0 1 4 5 9 .

    Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

    Input

    The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

    Output

    For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

    Sample Input

    5
    9
    1
    0
    5
    4
    3
    1
    2
    3
    0
    

    Sample Output

    6
    0

    解题思路:这个题目求的就是一串数的逆序数,但是必须用到归并排序,归并:关键在于如何把两个有序表合成一个,每次只需要把两个序列的最小元素加以比较,删除其中的较小元素并加入合并后的新表即可。思路:先把序列分成元素个数尽量相等的两半,r,l在两边尽量控制逆序对的个数,对于右边的每个数,统计左边比它大的个数。
    程序代码:
    #include<iostream>
    #include<cstdio>
    using namespace std;
    long long cnt;
    int A[500005],T[500005];
    void merge_sort(int l,int r)
    {
        if(r-l>1)
        {
            int m=l+(r-l)/2;
            int p=l,q=m,i=l;
            merge_sort(l,m);
            merge_sort(m,r);
            while(p<m || q<r)
            {
                if(q>=r || (p<m && A[p]<=A[q]) ) T[i++]=A[p++];
                else {
                    T[i++]=A[q++];
                    cnt+=m-p;
                    }
            }
            for(i=l;i<r;++i) A[i]=T[i];
        }
    }
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            cnt=0;
            for(int i=0;i<n;++i)
               scanf("%d",&A[i]);
            merge_sort(0,n);
            cout<<cnt<<endl;
        }
        return 0;
    }
    View Code
    版权声明:此代码归属博主, 请务侵权!
  • 相关阅读:
    SpringBoot异步处理请求
    5本最佳的 Java 面向对象理论和设计模式的书籍
    彻底弄懂 HTTP 缓存机制 —— 基于缓存策略三要素分解法
    Java 性能优化的五大技巧
    Java 8 最佳技巧
    Java 并发的四种风味:Thread、Executor、ForkJoin 和 Actor
    在 Java 8 中避免 Null 检查
    关于创建java线程池问题的思考
    LuoguP1858 多人背包(DP)
    Luogu[YNOI2019]排序(DP,线段树)
  • 原文地址:https://www.cnblogs.com/www-cnxcy-com/p/4711638.html
Copyright © 2011-2022 走看看