zoukankan      html  css  js  c++  java
  • ACM 辗转相除法(求最大公约数 )

    Description

    There is a hill with n holes around. The holes are signed from 0 to n-1. 



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
     

    Input

    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
     

    Output

    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
     

    Sample Input

    2
    1 2
    2 2
     

    Sample Output

    NO
    YES
    解题思路:
    题目就是让我们求最大公约数,如果两个数的最大公约数等于1,就输出NO,否则输出YES。我们用辗转相除法求最大公约数
    程序代码:
    #include <iostream>
    using namespace std;
    int gcd(int a,int b)
    {
         return b==0 ? a : gcd(b,a%b);
    }
    int main()
    {
    	int t;
    	cin>>t;
    	while(t--)
    	{
    		int m,n;
    		cin>>m>>n;
    		int p=gcd(m,n);
    		if(p==1)
    			cout<<"NO"<<endl;
    		else
    			cout<<"YES"<<endl;
    	}
    	return 0;
    }
    

      

     
     
     
     
  • 相关阅读:
    大话设计模式-原型模式
    Unity3D实习生面试题总结-图形学相关
    UnityShader入门精要-渲染流水线
    大话设计模式-工厂方法模式
    大话设计模式-代理模式
    C#中的值类型和引用类型
    【树结构】树链剖分简单分析
    HEOI2016排序-解题报告
    普通筛法时间界的证明
    可持久化线段树
  • 原文地址:https://www.cnblogs.com/xinxiangqing/p/4737967.html
Copyright © 2011-2022 走看看