zoukankan      html  css  js  c++  java
  • 输出问题问题一百二十八:IBM Minus One

    每日一贴,今天的内容关键字为输出问题

        

    You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

    After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

    Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

        Input

        

    The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

        Output

        每日一道理
    整个世界,因为有了阳光,城市有了生机;细小心灵,因为有了阳光,内心有了舒畅。明媚的金黄色,树丛间小影成像在叶片上泛有的点点破碎似的金灿,海面上直射反映留有的随波浪层层翻滚的碎片,为这大自然创造了美景,惹人醉的温馨之感,浓浓暖意中夹杂着的明朗与柔情,让雨过天晴后久违阳光的心灵重新得到了滋润!

        

    For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

    Print a blank line after each test case.

        Sample Input

    2
    HAL
    SWERC

        Sample Output

    String #1
    IBM
    
    String #2
    TXFSD
    
    
    #include <stdio.h>
    #include <string.h>
    
    int main()
    {
         int  length;
         int  num;
         int i;
         int  count=1;
         char array[51];
    
         scanf("%d", &num);
         getchar();
    
         while(num--)
         {    
              gets(array);
       
              length=strlen(array);
              for(i=0; i<length; i++)
              {
                  if(array[i]>='A' && array[i]<'Z')
                  {
                      array[i]+=1;
                  }
                  else if(array[i]=='Z')
                  {
                      array[i]='A';
                  }
              }
              printf("String #%d\n", count++);
    
              for(i=0; i<length; i++)
              {
                  printf("%c", array[i]);          
              }
              
                  printf("\n\n");
              
         }
    
         return 0;
    }

    (该题输出有点问题,即输出都空行)

    文章结束给大家分享下程序员的一些笑话语录: 问答
    Q:你是怎么区分一个内向的程序员和一个外向的程序员的? A:外向的程序员会看着你的鞋和你说话时。
    Q:为什么程序员不能区分万圣节和圣诞节? A:这是因为 Oct 31 == Dec 25!(八进制的 31==十进制的 25)

  • 相关阅读:
    阿里云弹性计算研发团队如何从0到1自建SRE体系
    开创云端时空智能,千寻位置加速三维实景中国建设
    实时复制真实世界,51World用云上数字孪生变革产业
    阿里云弹性计算性能测试负责人三年实战复盘 | 性能测试没那么简单
    阿里技术实战:一些云上资源调度的经验谈
    阿里云第七代云服务器,引领IaaS市场四大趋势
    最新干货!如何深入集群调度与管理?
    E2E性能再攀高峰、安全再加码,阿里云第七代ECS云服务器正式进入公测阶段
    centos7装linux翻译软件
    MySql 5.7中添加用户,新建数据库,用户授权,删除用户,修改密码
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/3053000.html
Copyright © 2011-2022 走看看