zoukankan      html  css  js  c++  java
  • hdu_1018_Big Number_201308191556

    Big Number
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 21214    Accepted Submission(s): 9549


    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.

    Sample Input
    2
    10
    20
     

    Sample Output
    7
    19
     

    //Big Number

    #include <stdio.h>
    #include <math.h>

    int main()
    {
        int N;
        scanf("%d",&N);
        while(N--)
        {
            int i,m;
            double sum=1;
            scanf("%d",&m);
            for(i=1;i<=m;i++)
            {
                sum+=log10(i);
            }
            printf("%d ",(int)sum);
        }
        return 0;
    }

  • 相关阅读:
    c++关于map的find和count的使用
    leetcode Two Sum
    leetcode Group Anagrams
    机器学习常见算法分类汇总
    KD树
    偏差与方差(未完)
    线性模型
    决策树
    Linux服务器配置---ftp用户黑名单
    Linux基础命令---mkdir
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3268269.html
Copyright © 2011-2022 走看看