zoukankan      html  css  js  c++  java
  • poj 1163 The Triangle 搜索 难度:0

    The Triangle
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 37931   Accepted: 22779

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30
    记忆化搜索
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    const int maxn=211;
    int  num[maxn][maxn];
    int n,m;
    int maz[maxn][maxn];
    const int dx[2]={1,1},dy[2]={0,1};
    int dfs(int sx,int sy){
        if(num[sx][sy]!=-1)return num[sx][sy];
        int tmp=maz[sx][sy];
        for(int i=0;i<2;i++){
            int tx=sx+dx[i],ty=sy+dy[i];
            if(tx>=0&&tx<n&&ty>=0&&ty<tx+1){
                int t=dfs(tx,ty);
                tmp=max(t+maz[sx][sy],tmp);
            }
        }
        return num[sx][sy]=tmp;
    }
    int main(){
        int T=1;
        while(T--&&scanf("%d",&n)==1){
            for(int i=0;i<n;i++){
                for(int j=0;j<i+1;j++){
                    scanf("%d",maz[i]+j);
                }
            }
            memset(num,-1,sizeof(num));
            int ans=0;
            for(int i=0;i<n;i++){
                for(int j=0;j<i+1;j++){
                    if(num[i][j]==-1){
                        int tmp=dfs(i,j);
                        ans=max(ans,tmp);
                    }
                }
            }
            printf("%d\n",ans);
        }
        return 0;
    }
    

      

  • 相关阅读:
    Splay复习
    带权并查集复习-HDU3038
    罗素悖论-图灵停机问题
    数独解法c++实现
    状压DP NOI2001 炮兵阵地
    区间第k大数
    分块随笔T2
    分块感想
    webkit的高级属性
    设计模式
  • 原文地址:https://www.cnblogs.com/xuesu/p/3983123.html
Copyright © 2011-2022 走看看