zoukankan      html  css  js  c++  java
  • HDU1003 简单DP

    Max Sum

    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6
    #include <bits/stdc++.h>
    using namespace std;
    const int MAXN = 100000 + 10;
    int T, n;
    int arr[MAXN], dp[MAXN];
    int S, E;
    int main() {
          scanf("%d", &T);
          for(int t = 0; t < T; ++t) {
                S = E = 0;
                cin >> n;
                for(int i = 0; i != n; ++i)
                      cin >> arr[i];
                dp[0] = arr[0];
                for(int i = 1; i != n; ++i)
                      if(dp[i-1] >= 0)
                            dp[i] = dp[i-1] + arr[i];
                      else
                            dp[i] = arr[i];
                int Max = dp[0];
                for(int i = 1; i != n; ++i)
                      if(dp[i] >= Max) {
                            Max = dp[i];
                            E = i;
                      }
                int sum = 0;
                for(int i = E; i >= 0; --i) {
                      sum += arr[i];
                      if(sum == Max)
                            S = i;
                }
                cout << "Case " << t+1 << ":" << endl;
                cout << Max << " " << S+1 << " " << E+1 << endl;
                if(t < T-1) puts("");
          }
          return 0;
    }
    用了数组
    #include <bits/stdc++.h>
    using namespace std;
    
    int main() {
          int T,n;
          int Max, S, E, sum, a;
          cin >> T;
          for(int t = 1; t <= T; ++t) {
                cin >> n;
                S = E = sum = 0;
                Max = -100000;
                int k = 0;
                for(int i = 0; i != n; ++i) {
                      cin >> a;
                      sum += a;
                      if(sum > Max) {
                            Max = sum;
                            S = k;
                            E = i;
                      }
                      if(sum < 0) {
                            sum = 0;
                            k = i + 1;
                      }
                }
                cout << "Case " << t << ":" << endl;
                cout << Max << " " << S+1 << " " << E+1 << endl;
                if(t < T) puts("");
          }
          return 0;
    }
    不用数组
  • 相关阅读:
    软件缺陷管理流程
    JMeter学习(三十五)使用jmeter来发送json/gzip格式数据
    如何转做测试管理?
    新加入一个团体,如何能尽快的展开测试工作(转载)
    JMeter学习(三十四)测试报告优化
    Jmeter学习(三十三)调试工具Debug Sampler
    java设计模式
    Android Studio提示 Connection reset
    加速Android Studio编译速度
    Exception in thread "main" java.lang.StackOverflowError at java.util.ArrayList$SubList.rangeCheckForAdd(Unknown Source)
  • 原文地址:https://www.cnblogs.com/ya-cpp/p/4679324.html
Copyright © 2011-2022 走看看