zoukankan      html  css  js  c++  java
  • UVa11059

    Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
    maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
    you should consider 0 as the value of the maximum product.


    Input
    Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
    is
    an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
    element in the sequence. There is a blank line after each test case. The input is terminated by end of
    file (EOF).


    Output
    For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
    M is the number of the test case, starting from 1, and P is the value of the maximum product. After
    each test case you must print a blank line.


    Sample Input
    3
    2 4 -3
    5
    2 5 -1 2 -1


    Sample Output
    Case #1: The maximum product is 8.
    Case #2: The maximum product is 20.

    题意:输入n个元素组成的序列S,你需要找出一个乘积最大的连续子序列 。如果这个最大的乘积不是正数,就输出0(表示无解)。 1<=n<=18   -10<=S<=10

    输出格式  每输出一组案例就空一行(注意)

    程序分析:连续子序列有两个要素:起点和重点。所以只要枚举起点和终点就好。由于每个元素与的最大值不会超过10,且不超过18个元素,最大乘积不会超过10的18次方。所以可以用long long储存(试了一下,用int的话,输出18个10的结果不对,int存不下)

    程序代码:

    #include <stdio.h>
    int a[20];
    int main()
    {
        int n,N=0,c2=0;
        while(scanf("%d",&n)==1)
        {
            long long c,c2=0;
            ++N;
            for(int i=0; i<n; i++)
                scanf("%d",&a[i]);
            for(int q=0;q<n;q++)
            {
                c=1;
                for(int z=q;z<n;z++)
                {
                    c*=a[z];
                    if(c>c2)
                        c2=c;
                }
            }
            if(c2<=0)
                printf("Case #%d: The maximum product is 0.
    
    ",N);
            else
                printf("Case #%d: The maximum product is %lld.
    
    ",N,c2);
        }
        return 0;
    }
  • 相关阅读:
    Redis主从复制
    maven生命周期和插件
    maven私服搭建
    为公司运营人员整理EXCEL数据小程序
    docker之本地镜像上传阿里云
    docker阿里云镜像之Tomcat
    docker环境安装
    网页及第三方连接禅道数据库
    yagmail 发送HTML格式邮件图片不显示问题解决方案
    pyechars模块安装踩得坑
  • 原文地址:https://www.cnblogs.com/yilihua/p/4686977.html
Copyright © 2011-2022 走看看