zoukankan      html  css  js  c++  java
  • 1050. String Subtraction (20)

    题目例如以下:

    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1 - S2 in one line.

    Sample Input:
    They are students.
    aeiou
    
    Sample Output:
    Thy r stdnts.
    


    题目要求从字符串S1中删除全部S2中有的字符。最简单的解决方法就是S1用string,S2用map,然后遍历输出S1。对于S1中的每个字符,假设map中有,则不输出。

    须要注意的是对空格的处理。使用getline(cin,str)能够读取一行。从而实现string中存储带空格字符串,使用getchar()函数能够捕捉到空格和回车,以此输入S2到map。

    代码例如以下:

    #include <iostream>
    #include <string>
    #include <string.h>
    #include <stdio.h>
    #include <map>
    
    using namespace std;
    
    int main()
    {
        string input,del;
        getline(cin,input);
        map<char,int> strs;
        while(1){
            char c = getchar();
            if(c == '
    ') break;
            strs[c] = 1;
        }
        for(int i = 0; i < input.length(); i++){
            char c = input[i];
            if(strs.find(c) != strs.end()) continue;
            printf("%c",c);
        }
        cout << endl;
        return 0;
    }
    


  • 相关阅读:
    C# 中类重写 ToString 方法
    虚方法(virtual)和抽象方法(abstract)的区别
    C#的扩展方法学习
    C# .NET 和.NET Framework区别
    C#值类型和引用类型
    抽象和接口的区别和使用
    什么是委托?
    什么是继承?
    设计模式:单一职责原则
    Java 13,最新最全新特性解读
  • 原文地址:https://www.cnblogs.com/yxysuanfa/p/7007101.html
Copyright © 2011-2022 走看看