zoukankan      html  css  js  c++  java
  • poj 1042 Gone Fishing 贪心

    Gone Fishing
    Time Limit: 2000MS   Memory Limit: 32768K
    Total Submissions: 39267   Accepted: 12205

    Description

    John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
    Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

    Input

    You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

    Output

    For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
    If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

    Sample Input

    2 
    1 
    10 1 
    2 5 
    2 
    4 
    4 
    10 15 20 17 
    0 3 4 3 
    1 2 3 
    4 
    4 
    10 15 50 30 
    0 3 4 3 
    1 2 3 
    0 

    Sample Output

    45, 5 
    Number of fish expected: 31 
    
    240, 0, 0, 0 
    Number of fish expected: 480 
    
    115, 10, 50, 35 
    Number of fish expected: 724 


    枚举在前n个池塘中钓鱼,分别减去时间,然后就能实现在选中的湖间瞬间移动————哪个多去哪里捞,最后比较得出答案。

    ac代码:
    #include<iostream>
    #include<cmath>
    #include<stdio.h>
    #include<vector>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int maxn=26;
    int n,h,dt[maxn],i,j,k,ans,anst[maxn];
    vector<int> f,d;
    
    bool check(int*a,int *b,int i)
    {
          for(int j=0;j<=i;j++)
          {
                if(b[j]>a[j])
                      return true;
                else if(b[j]<a[j])
                      return false;
          }
    }
    int main(void)
    {
     //     freopen("input.txt","r",stdin);
          while(cin>>n&&n)
          {
                ans=0;
                memset(anst,0,sizeof anst);
                f.clear();
                d.clear();
                cin>>h;
                h*=12;
                for(i=1;i<=n;i++)
                {
                      scanf("%d",&k);
                      f.push_back(k);
                }
                for(i=1;i<=n;i++)
                {
                      scanf("%d",&k);
                      d.push_back(k);
                }
                for(i=1;i<n;i++)
                {
                      scanf("%d",&dt[i]);
                }
                dt[0]=0;
    
                //贪心
                for(i=0;i<n;i++)
                {
                      vector<int>f1(f);
                      vector<int>d1(d);
    
                      h-=dt[i];
                      int ans1=0;
                      int anst1[maxn];
                      memset(anst1,0,sizeof anst1);
                      for(j=h;j>0;j--)
                      {
                            int maxi=0;
                            for(k=1;k<=i;k++)
                            {
                                  if(f1[k]>f1[maxi])
                                        maxi=k;
                            }
                            int dx=f1[maxi]>d1[maxi]?d1[maxi]:f1[maxi];
                            ans1+=f1[maxi];
                            f1[maxi]-=dx;
                            anst1[maxi]++;
                      }
                      if(ans1>ans||ans1==ans&&check(anst,anst1,i))
                      {
                            ans=ans1;
                            for(k=0;k<=i;k++)
                                  anst[k]=anst1[k]*5;
                      }
                }
                //output
                for(i=0;i<n;i++)
                {
                      cout<<anst[i];
                      if(i!=n-1)
                            cout<<", ";
                }
                cout<<endl<<"Number of fish expected: "<<ans<<endl<<endl;
    
          }
          return 0;
    }
    

      

  • 相关阅读:
    Wireshark——工具
    Wireshark——网络协议
    Wireshark——过滤器
    Wireshark——数据包、着色规则和提示
    Floyd最小环
    有向环覆盖问题
    KM算法
    归并排序
    树状数组
    构造强连通图
  • 原文地址:https://www.cnblogs.com/zgncbsylm/p/10572875.html
Copyright © 2011-2022 走看看