zoukankan      html  css  js  c++  java
  • 1032 Sharing (25 分)使用set实现

    1032 Sharing (25 分)

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

    fig.jpg

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (105​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by 1.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    

    whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

    Output Specification:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

    Sample Input 1:

    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    

    Sample Output 1:

    67890
    

    Sample Input 2:

    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    

    Sample Output 2:

    -1
    思路:
      1、这次我参考网上的代码没有使用map,而是使用结构体数组。不同之处在于,我没有使用visit这个变量,而是在遍历第一个链表的时候
    把地址放在了set中,遍历第二个链表的时候在set中查找地址,如果有直接输出,没有的话则输出-1.当然时间复杂度会大一点,但是略微好
    思考一点,还好这次通过了。
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    set<int> s;
    struct Node
    {
       // int start;
        char data;
        int next;
    }node[1000000];
    
    
    
    int main()
    {
        int addressA,addressB,n;
        scanf("%d%d%d",&addressA,&addressB,&n);
        for(int i=0;i<n;i++)
        {
            int start;
            scanf("%d",&start);
            scanf(" %c%d",&node[start].data,&node[start].next);
        }
        for(int i=addressA;i!=-1;i=node[i].next)
            s.insert(i);
        for(int i=addressB;i!=-1;i=node[i].next)
        {
            if(s.find(i)!=s.end())
            {
                printf("%05d",i);
                return 0;
            }
        }
        printf("-1");
        return 0;
    }
     
  • 相关阅读:
    「Baltic2015」Network
    noip模拟赛 蒜头君的排序
    noip模拟赛 蒜头君的兔子
    codevs2171 棋盘覆盖
    noip模拟赛 蒜头君的坐骑
    noip模拟赛 蒜头君的树
    noip模拟赛 蒜头君打地鼠
    noip模拟赛 密码
    noip模拟赛 轰炸
    noip模拟赛 毁灭
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10299636.html
Copyright © 2011-2022 走看看