zoukankan      html  css  js  c++  java
  • Hdu 1326 Box of Bricks

    Box of Bricks

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7651    Accepted Submission(s): 3347

    Problem Description

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

     

    Input

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.

    Output

    For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

    Output a blank line after each set.

    Sample Input

    6

    5 2 4 1 7 5

    0

    Sample Output

    Set #1

    The minimum number of moves is 5.

    #include<iostream>
    #include<math.h> 
    using namespace std;   
    int main()
    { 
       int n,ave,sum;
       int s[51];
       int i;
       int count=0;
       while(cin>>n,n)
       {
        ave=sum=0;
        for(i=0;i<n;i++)
     {
      cin>>s[i];
      ave+=s[i];
     }
     ave/=n;
        for(i=0;i<n;i++)
      sum+=abs(s[i]-ave);
     sum/=2;
     cout<<"Set #"<<++count<<endl;
     cout<<"The minimum number of moves is "<<sum<<"."<<endl<<endl; //万恶的格式。   }
        return 0; 
    }
    

      

  • 相关阅读:
    MySQL系列
    Python小白之路
    nrm安装使用(mac)
    npm 发布一个包(已有自己私服的情况)
    vuex简单使用
    在vue中使用ztree树插件
    题库1
    设计模式读书笔记
    ORM框架学习之EF
    net+Oracle开发过程中遇到的小问题
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7058011.html
Copyright © 2011-2022 走看看