zoukankan      html  css  js  c++  java
  • POJ1789:Truck History(Prim算法)

    http://poj.org/problem?id=1789

    Description

    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
    1/Σ(to,td)d(to,td)

    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

    Input

    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

    Output

    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

    Sample Input

    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    

    Sample Output

    The highest possible quality is 1/3.

    此题难点在于读题,明白题意后就是一个很简单的最小生成树

    明白一点就行:将每一个卡车类型代码(truck type codes)作为一个结点,任意两个 卡车类型代码中 相同位置即字符数组a[i],a[i+1] 上 a[i]和a[i+1]为不同字符的位置的个数 做为

                                 这两个结点之间的路径的权值。

    读题啊,硬伤啊!

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #define INF 0x3f3f3f3f
    using namespace std;
    char a[2001][8];
    int map[2001][2001];
    int n,dis[2001],v[2001];
    void prim()
    {
        int min,sum=0,k;
        for(int i=1; i<=n; i++)
        {
            v[i]=0;
            dis[i]=INF;
        }
        for(int i=1; i<=n; i++)
            dis[i]=map[1][i];
        v[1]=1;
        for(int j=1; j<n; j++)
        {
            min=INF;
            for(int i=1; i<=n; i++)
            {
                if(v[i]==0&&dis[i]<min)
                {
                    k=i;
                    min=dis[i];
                }
            }
            sum+=min;
            v[k]=1;
            for(int i=1; i<=n; i++)
            {
                if(v[i]==0&&map[k][i]<dis[i])
                {
                    dis[i]=map[k][i];
                }
            }
        }
        cout<<"The highest possible quality is 1/"<<sum<<"."<<endl;
    }
    int main()
    {
        int count;
        while(scanf("%d",&n)!=EOF&&n!=0)
        {
            for(int i=1; i<=n; i++)
                scanf("%*c%s",a[i]);
            for(int i=1; i<=n; i++)
            {
                for(int j=i+1; j<=n; j++)
                {
                    count=0;
                    for(int k=0; k<7; k++)
                        if(a[i][k]!=a[j][k])
                        {
                            count++;
                        }
                    map[i][j]=count;
                    map[j][i]=count;
                }
            }
            prim();
        }
        return 0;
    }
  • 相关阅读:
    vs2010 setup 打包 安装 BAT批处理实现自动安装软件功能
    为什么我上传了flv或MP4文件到服务器,可输入正确地址通过http协议来访问总是出现“无法找到该页”的404错误呢
    异步编程:(TAP)基于任务的异步编程模型详解
    异步编程:IAsyncResult异步编程模型 (APM)
    WCF:调用方未由服务器进行身份验证
    django 操作数据库--orm(object relation mapping)---models
    python操作memcached以及分布式
    网络干货,无论是运维还是开发都要知道的网络知识系列之(七)
    一次完整的HTTP事务是怎样一个过程?
    网络干货,无论是运维还是开发都要知道的网络知识系列之(六)
  • 原文地址:https://www.cnblogs.com/zhangmingcheng/p/3969173.html
Copyright © 2011-2022 走看看