zoukankan      html  css  js  c++  java
  • hdoj 1754 I Hate It 线段树(二)

    I Hate It

    Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 23222    Accepted Submission(s): 9286


    Problem Description
    很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
    这让很多学生很反感。

    不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
     
    Input
    本题目包含多组测试,请处理到文件结束。
    在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
    学生ID编号分别从1编到N。
    第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
    接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
    当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
    当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
     
    Output
    对于每一次询问操作,在一行里面输出最高成绩。
     
    Sample Input
    5 6
    1 2 3 4 5
    Q 1 5
    U 3 6
    Q 3 4
    Q 4 5
    U 2 9
    Q 1 5
    Sample Output
    5
    6
    5
    9
    代码:
    #include<stdio.h>
    struct node
    {
        int left;
        int right;
        int date;
        int max;
    };
    node tree[800001];
    int maxv;
    void Creattree(int k,int a,int b)
    {
        tree[k].left=a;
        tree[k].right=b;
        tree[k].date=tree[k].max=0;
        if(a==b)
        {
            return;
        }
        else
        {
            int mid=(a+b)/2;
            Creattree(k*2,a,mid);
            Creattree(k*2+1,mid+1,b);
        }
    }
    void update(int k,int a,int num)
    {
        if(tree[k].left==a&&tree[k].right==a)
        {
            tree[k].date=num;
            tree[k].max=num;
        }
        else
        {
            int mid=(tree[k].left+tree[k].right)/2;
            if(a<=mid)
            {
                update(k*2,a,num);
            }
            else
            {
                update(k*2+1,a,num);
            }
            if(num>tree[k].max)
                tree[k].max=num;
        }
    }
    void find(int k,int a,int b)
    {
        if(tree[k].left==a&&tree[k].right==b)
        {
            if(tree[k].max>maxv)
                maxv=tree[k].max;
        }
        else
        {
            int mid=(tree[k].left+tree[k].right)/2;
            if(b<=mid)
            {
                find(k*2,a,b);
            }
            else if(a>mid)
            {
                find(k*2+1,a,b);
            }
            else
            {
                find(k*2,a,mid);
                find(k*2+1,mid+1,b);
            }
    
        }
    }
    
    
    
    int main()
    {
        int n,m,x,y,num,i;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            Creattree(1,1,n);
            for(i=1;i<=n;++i)
            {
                scanf("%d",&num);
                update(1,i,num);
            }
            char c;
            while(m--)
            {
                scanf("%*c%c",&c);
                scanf("%d%d",&x,&y);
                if(c=='U')
                    update(1,x,y);
                else
                {
                    maxv=-1;
                    find(1,x,y);
                    printf("%d\n",maxv);
                }
            }
        }
        return 0;
    }

    由于本题有多组输入,故要用数组去存,不然不够。

  • 相关阅读:
    SP笔记:交叉实现七行并成一行
    HTML tag 学习
    操作哈希表
    Efficient bipedal robots based on passivedynamic walkers
    Pushing People Around
    ZEROMOMENT PONTTHIRTY FIVE YEARS OF ITS LIFE

    Active Learning for RealTime Motion Controllers
    Accelerometerbased User Interfaces for the Control of a Physically Simulated Character
    Dynamic Response for Motion Capture Animation
  • 原文地址:https://www.cnblogs.com/zibuyu/p/3034324.html
Copyright © 2011-2022 走看看