zoukankan      html  css  js  c++  java
  • POJ 2253 Frogger

    http://poj.org/problem?id=2253

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    #include <math.h>
    #include <string.h>
    using namespace std;
    
    #define inf 0x3f3f3f3f
    int N;
    double mp[220][220];
    double dis[220];
    int vis[220];
    
    struct Node {
        int x;
        int y;
    }node[220];
    
    double Dis(int a, int b) {
        return sqrt((double)(node[a].x - node[b].x) * (node[a].x - node[b].x) +
                    (node[a].y - node[b].y) * (node[a].y - node[b].y));
    }
    
    void dijkstra(int act) {
        memset(vis, 0, sizeof(vis));
        memset(dis, inf, sizeof(dis));
    
        for(int i = 1; i <= N; i ++) {
            if(mp[act][i] < inf)
                dis[i] = mp[act][i];
        }
    
        int temp = act;
        vis[act] = 0;
        dis[act] = 0;
    
        for(int i = 1; i <= N; i ++) {
            double minn = 1.0 * inf;
            for(int j = 1; j <= N; j ++) {
                if(dis[j] < minn && !vis[j]) {
                    minn = dis[j];
                    temp = j;
                }
            }
            vis[temp] = 1;
            for(int k = 1; k <= N; k ++)
                dis[k] = min(dis[k], max(dis[temp], mp[temp][k]));
        }
    }
    
    int main() {
        int Case = 1;
        while(~scanf("%d", &N)) {
            if(!N) break;
            memset(mp, inf, sizeof(mp));
            for(int i = 1; i <= N; i ++) {
                scanf("%d%d", &node[i].x, &node[i].y);
                for(int j = 1; j <= i; j ++)
                    mp[i][j] = mp[j][i] = Dis(i, j);
            }
            dijkstra(1);
            printf("Scenario #%d
    Frog Distance = ", Case ++);
            printf("%.3f
    
    ", dis[2]);
        }
        return 0;
    }
    

      

  • 相关阅读:
    07 总结ProgressDialog 异步任务
    1. vim 的安装及配置
    debian 源设置 ( apt-get 不能安装)
    在Debian中安装VNC Server
    让BB-Black通过usb0上网
    常用的一些 linux 指令
    Linux下同一目录内文件和目录为什么不能同名?
    beaglebone black 与电脑互传文件(夹)
    永久修改 putty字体大小
    Beaglebone Black的引脚分配
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9879160.html
Copyright © 2011-2022 走看看