zoukankan      html  css  js  c++  java
  • 59从二叉搜索树到更大和树(1038)

    作者: Turbo时间限制: 1S章节: 二叉搜索树

    晚于: 2020-08-12 12:00:00后提交分数乘系数50%

    截止日期: 2020-08-19 12:00:00

    问题描述 :

    给出二叉 搜索 树的根节点,该二叉树的节点值各不相同,修改二叉树,使每个节点 node 的新值等于原树中大于或等于 node.val 的所有节点的值之和。

    提醒一下,二叉搜索树满足下列约束条件:

    节点的左子树仅包含键 小于 节点键的节点。

    节点的右子树仅包含键 大于 节点键的节点。

    左右子树也必须是二叉搜索树。

    示例:

    tree.png

    输入:[4,1,6,0,2,5,7,null,null,null,3,null,null,null,8]

    输出:[30,36,21,36,35,26,15,33,8]

    可使用以下main函数:

    #include <iostream>

    #include <queue>

    #include <stack>

    #include<cstdlib>

    #include <cstring>

    #include<map>

    using namespace std;

    struct TreeNode

    {

        int val;

        TreeNode *left;

        TreeNode *right;

        TreeNode() : val(0), left(NULL), right(NULL) {}

        TreeNode(int x) : val(x), left(NULL), right(NULL) {}

        TreeNode(int x, TreeNode *left, TreeNode *right) : val(x), left(left), right(right) {}

    };

    TreeNode* inputTree()

    {

        int n,count=0;

        char item[100];

        cin>>n;

        if (n==0)

            return NULL;

        cin>>item;

        TreeNode* root = new TreeNode(atoi(item));

        count++;

        queue<TreeNode*> nodeQueue;

        nodeQueue.push(root);

        while (count<n)

        {

            TreeNode* node = nodeQueue.front();

            nodeQueue.pop();

            cin>>item;

            count++;

            if (strcmp(item,"null")!=0)

            {

                int leftNumber = atoi(item);

                node->left = new TreeNode(leftNumber);

                nodeQueue.push(node->left);

            }

            if (count==n)

                break;

            cin>>item;

            count++;

            if (strcmp(item,"null")!=0)

            {

                int rightNumber = atoi(item);

                node->right = new TreeNode(rightNumber);

                nodeQueue.push(node->right);

            }

        }

        return root;

    }

    void printTree(TreeNode* root) {

        if (root == NULL) {

          return;

        }

        bool isFirst=true;

        queue<TreeNode*> q;

        q.push(root);

        while(!q.empty()) {

            TreeNode* node = q.front();

            q.pop();

            if (node == NULL) {

              continue;

            }

            if (!isFirst)

                cout<<",";

            cout<<node->val;

            isFirst=false;

            q.push(node->left);

            q.push(node->right);

        }

    }

    int main()

    {

        TreeNode* root;

        root=inputTree();

        TreeNode* res=Solution().bstToGst(root);

        printTree(res);

    }

    输入说明 :

    首先输入结点的数目n(注意,这里的结点包括题中的null空结点)

    然后输入n个结点的数据,需要填充为空的结点,输入null。

    输出说明 :

    输出节点的信息,以逗号分隔

    输入范例 :

    输出范例 :

    #include <iostream>
    #include <queue>
    #include <stack>
    #include<cstdlib>
    #include <cstring>
    #include<map>
    using namespace std;
    struct TreeNode
    {
        int val;
        TreeNode *left;
        TreeNode *right;
        TreeNode() : val(0), left(NULL), right(NULL) {}
        TreeNode(int x) : val(x), left(NULL), right(NULL) {}
        TreeNode(int x, TreeNode *left, TreeNode *right) : val(x), left(left), right(right) {}
    };
    
    class Solution {
    public:
        int pre=0; 
        TreeNode* bstToGst(TreeNode* root) 
        {
            if(root==NULL)
                return NULL;
            bstToGst(root->right);
            pre=pre+root->val;
            root->val=pre;
            bstToGst(root->left);
            return root;
        }
    };
    
    TreeNode* inputTree()
    {
        int n,count=0;
        char item[100];
        cin>>n;
        if (n==0)
            return NULL;
        cin>>item;
        TreeNode* root = new TreeNode(atoi(item));
        count++;
        queue<TreeNode*> nodeQueue;
        nodeQueue.push(root);
        while (count<n)
        {
            TreeNode* node = nodeQueue.front();
            nodeQueue.pop();
            cin>>item;
            count++;
            if (strcmp(item,"null")!=0)
            {
                int leftNumber = atoi(item);
                node->left = new TreeNode(leftNumber);
                nodeQueue.push(node->left);
            }
            if (count==n)
                break;
            cin>>item;
            count++;
            if (strcmp(item,"null")!=0)
            {
                int rightNumber = atoi(item);
                node->right = new TreeNode(rightNumber);
                nodeQueue.push(node->right);
            }
        }
        return root;
    }
    void printTree(TreeNode* root) {
        if (root == NULL) {
          return;
        }
        bool isFirst=true;
        queue<TreeNode*> q;
        q.push(root);
        while(!q.empty()) {
            TreeNode* node = q.front();
            q.pop();
            if (node == NULL) {
              continue;
            }
            if (!isFirst)
                cout<<",";
            cout<<node->val;
            isFirst=false;
            q.push(node->left);
            q.push(node->right);
        }
    }
    int main()
    {
        TreeNode* root;
        root=inputTree();
        TreeNode* res=Solution().bstToGst(root);
        printTree(res);
    }

    主要就是从右往左遍历,直接改变节点的值,最后返回头结点

  • 相关阅读:
    HDU 1269 迷宫城堡
    HDU 4771 Stealing Harry Potter's Precious
    HDU 4772 Zhuge Liang's Password
    HDU 1690 Bus System
    HDU 2112 HDU Today
    HDU 1385 Minimum Transport Cost
    HDU 1596 find the safest road
    HDU 2680 Choose the best route
    HDU 2066 一个人的旅行
    AssetBundle管理机制(下)
  • 原文地址:https://www.cnblogs.com/zmmm/p/13636479.html
Copyright © 2011-2022 走看看