zoukankan      html  css  js  c++  java
  • Picture

    Problem Description
    Give you the width and height of the rectangle,darw it.
     
    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
     
    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.
     
    Sample Input
    3 2
     
    Sample Output
    +---+
    |   |
    |   |
    +---+
     
     
     
     
    #include <stdio.h>
    #include<string.h>
    int main()
    {
        int n, m;
        while( scanf( "%d%d", &n, &m ) == 2 )
        {
            printf( "+" );
            for( int i = 0; i < n; i++ )
                printf( "-" );
            printf( "+\n" );
            for( int j = 0; j < m; j++ )
              {
                      printf( "|" );
                         for( int i = 0; i < n; i++ )
                              printf( " " );
                    printf( "|\n" );
              }
              printf( "+" );
            for( int i = 0; i < n; i++ )
                printf( "-" );
            printf( "+\n" );
    puts( "" );
        }
        return 0;
    }

  • 相关阅读:
    算法:二分图最大独立集
    算法:桶排序
    算法:二分图最小点覆盖——Konig定理
    jQuery基础整理之思维导图
    vue基础知识整理
    HTML总结
    JAVAScript总结
    栈和队列
    今日学习遇到的问题(2018.9.23)
    看了vue文档之后。。。。
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2266738.html
Copyright © 2011-2022 走看看