zoukankan      html  css  js  c++  java
  • Picture

    Problem Description
    Give you the width and height of the rectangle,darw it.
     
    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
     
    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.
     
    Sample Input
    3 2
     
    Sample Output
    +---+
    |   |
    |   |
    +---+
     
     
     
     
    #include <stdio.h>
    #include<string.h>
    int main()
    {
        int n, m;
        while( scanf( "%d%d", &n, &m ) == 2 )
        {
            printf( "+" );
            for( int i = 0; i < n; i++ )
                printf( "-" );
            printf( "+\n" );
            for( int j = 0; j < m; j++ )
              {
                      printf( "|" );
                         for( int i = 0; i < n; i++ )
                              printf( " " );
                    printf( "|\n" );
              }
              printf( "+" );
            for( int i = 0; i < n; i++ )
                printf( "-" );
            printf( "+\n" );
    puts( "" );
        }
        return 0;
    }

  • 相关阅读:
    hdu 5366 简单递推
    hdu 5365 判断正方形
    hdu 3635 并查集
    hdu 4497 数论
    hdu5419 Victor and Toys
    hdu5426 Rikka with Game
    poj2074 Line of Sight
    hdu5425 Rikka with Tree II
    hdu5424 Rikka with Graph II
    poj1009 Edge Detection
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2266738.html
Copyright © 2011-2022 走看看