zoukankan      html  css  js  c++  java
  • HDU

    E - Super Jumping! Jumping! Jumping!

     

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 
    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 
    Output
    For each case, print the maximum according to rules, and one line one case. 
    Sample Input
    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
    Sample Output
    4
    10
    3


    确定状态:dp[i]表示以i数字为结尾的单调递增子序列

    状态转移方程:dp[i]=max(dp[i],dp[j]+arr[i]);

    求单调递增子序列  

    #include <bits/stdc++.h>
    using namespace std;
    #define INF 0x3f3f3f3f
    #define maxn 1010
    
    int arr[maxn];
    int dp[maxn];///dp[i]是以第i个字母结尾的递增子序列的个数
    
    int main() {
        int n;
    	while(~scanf("%d",&n) && n!=0)
    	{
    	    for(int i=0;i<n;i++)
    		    scanf("%d",&arr[i]);
    		int ans=0;
    		for(int i=0;i<n;i++)
    		{
    			dp[i]=arr[i];
    			for(int j=0;j<i;j++)
                    if(arr[i]>arr[j])
    				  dp[i]=max(dp[i],dp[j]+arr[i]);
    		}
    		int mmax=-INF;
    		for(int i=0;i<n;i++)
                mmax=max(mmax,dp[i]);
    		cout<<mmax<<endl;
    	}
    	return 0;
    }
    




  • 相关阅读:
    App_Data文件夹的用处.
    .net工资管理系统 C#2.0开发
    红警2尤里的复仇 无限金钱 无限电力修改器
    用bho方式拦截中国电信流氓广告
    仙剑4按键取钱的东东。
    多浏览器测试的利器IETester,自带IE5.5,IE6,IE7,IE8等多个内核.
    dataGridView使用指南系列一、回车换行或换列完美解决方案
    红警2共和国之辉无限金钱修改器,造东西不花钱还赚钱。
    UpdatePanel控件,你真的会用了吗?
    XP+WIN7共享动态磁盘的一点收获
  • 原文地址:https://www.cnblogs.com/zswbky/p/6792920.html
Copyright © 2011-2022 走看看