zoukankan      html  css  js  c++  java
  • 集训第四周(高效算法设计)L题 (背包贪心)

    Description

    Download as PDF
     

    John Doe is a famous DJ and, therefore, has the problem of optimizing the placement of songs on his tapes. For a given tape and for each song on that tape John knows the length of the song and the frequency of playing that song. His problem is to record the songs on the tape in an order that minimizes the expected access time. If the songs are recorded in the order S(s1),..., Ss(n)<tex2html_verbatim_mark> on the tape then the function that must be minimized is

    $displaystyle sum^{{n}}_{{i=1}}$fs(i)$displaystyle sum^{{s(i)}}_{{j=1}}$ls(j)

    <tex2html_verbatim_mark>

    where fs(i)<tex2html_verbatim_mark> is the frequency of playing the i<tex2html_verbatim_mark> -th song and l<tex2html_verbatim_mark> is the length of the song. Can you help John?

    Input 

    The program input is from a text file. Each data set in the file stands for a particular set of songs that must be recorded on a tape. A data set starts with the number N<tex2html_verbatim_mark> (fits a 16 bit integer) of songs. Follow N<tex2html_verbatim_mark> the song specifications, and in the end, a number representing the position of a song S<tex2html_verbatim_mark> on the optimized tape. A song specification consists of the song identifier (fits an integer), the length of the song (fits a 16 bit integer), and the frequency of playing the song (a floating-point number). The program prints the identifier of the song S<tex2html_verbatim_mark> .

    White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output 

    For each set of data the program prints the result to the standard output from the beginning of a line.


    Note: An input/output sample is in the table below. There is a single data set that contains 5 song specifications. The first song has the identifier 1, length 10 and playing frequency 45.5 etc. The result for the data set is the identifier of the 3rd song on the optimized tape. It is 2 for the given example.

    Sample Input 

    5
    1      10     45.5
    2      5      20 
    30     20     10 
    400    50     35 
    15     17     89.9
    3
    

    Sample Output 

    2
    题意:给你一份歌单,其中包括歌曲号,歌曲时长还有歌曲被点播的频率,要求你刻录这些歌到一张光碟里,不同的刻录顺序,光碟也就不同,要求的顺序是让上面给出的公式的值尽可能地小
    思路:其实看懂了,就知道这不就是背包贪心问题么。。。。。。

    #include"iostream"
    #include"algorithm"
    using namespace std;
    const int maxn=100000;
    
    struct node
    {
        int x;
        double y;
    }a[maxn];
    
    bool cmp(struct node a1,struct node a2)
    {
        return a1.y>a2.y;
    }
    
    int main()
    {
        int n;
        while(cin>>n)
        {
        int t,id;double f;
        for(int i=0;i<n;i++)
        {
         cin>>id>>t>>f;
         a[i].x=id;
         a[i].y=f/t;
        }
        sort(a,a+n,cmp);
        int temp;
        cin>>temp;
        cout<<a[temp-1].x<<endl;
        }
        return 0;
    }
    

     

  • 相关阅读:
    汉字获取首字母
    .net 实现对DNS服务器的管理
    css使图片变灰
    javascript实现文本框只能输入数字和字母
    解决Outlook不能打开的问题
    javascript实现弹出式登录界面
    asp.net防盗链技术
    javascript中replace()(转帖)
    chm文件无法显示问题
    使用Lucene.NET进行分词、搜索
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/4705541.html
Copyright © 2011-2022 走看看