zoukankan      html  css  js  c++  java
  • HDU 1671 Phone List (Trie)

    Phone List

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 12879    Accepted Submission(s): 4391


    Problem Description
    Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
    1. Emergency 911
    2. Alice 97 625 999
    3. Bob 91 12 54 26
    In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
     

    Input
    The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
     

    Output
    For each test case, output “YES” if the list is consistent, or “NO” otherwise.
     

    Sample Input
    2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
     

    Sample Output
    NO YES
     

    Source



    解析:求是否为非前缀串(即随意串的前缀都不是一个已有的串)。在建Trie树时,仅仅标记串的最后一个字符,然后查询时,看每一个串的中间是否存在被标记的点就可以。




    AC代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    const int maxnode = 100000 * 10 + 5;
    const int sigma_size = 10;
    
    struct Trie{
        int ch[maxnode][sigma_size];
        int val[maxnode];
        int sz;
    
        void clear(){ sz = 1; memset(ch[0], 0, sizeof(ch[0])); }  //初始仅仅有一个根节点
        int idx(char c){ return c - '0'; }
    
        void insert(string s){
            int u = 0, n = s.size();
            for(int i=0; i<n; i++){
                int c = idx(s[i]);
                if(!ch[u][c]){
                    memset(ch[sz], 0, sizeof(ch[sz]));
                    val[sz] = 0;
                    ch[u][c] = sz++;
                }
                u = ch[u][c];
            }
            val[u] ++;    //仅仅标记串尾的字符
        }
    
        bool find(string s){
            int u = 0, n = s.size();
            for(int i=0; i<n; i++){
                int c = idx(s[i]);
                if(val[u]) return false;    //在一个串的中间出现了已经标记的点
                u = ch[u][c];
            }
            return true;
        }
    
    };
    
    Trie T;
    vector<string> S;
    
    int main(){
        #ifdef sxk
            freopen("in.txt", "r", stdin);
        #endif // sxk
    
        int t, n;
        string s;
        scanf("%d", &t);
        while(t--){
            S.clear();
            T.clear();       //不要忘了初始化
            scanf("%d", &n);
            for(int i=0; i<n; i++){
                cin>>s;
                T.insert(s);
                S.push_back(s);
            }
            int cnt = S.size();
            int i;
            for(i=0; i<cnt; i++){
                if(!T.find(S[i])) break;
            }
            puts(i < cnt ?

    "NO" : "YES"); } return 0; }





  • 相关阅读:
    对称加密算法在C#中的踩坑日常
    php与Git下基于webhook的自动化部署
    1024程序员节阿里谜题解析
    一次ajax请求导致status为canceled的原因小记
    LigerUI下拉选择列表LigerComboBox中tree的节点初始化默认选中的问题
    linux环境下安装PHP扩展swoole
    Memcache PHP 使用笔记
    VS生成事件执行XCOPY时出现Invalid num of parameters的解决方案
    mysql表的完整性约束
    mysql支持的数据类型
  • 原文地址:https://www.cnblogs.com/zsychanpin/p/7355868.html
Copyright © 2011-2022 走看看