zoukankan      html  css  js  c++  java
  • 1155.Heap Paths-PAT甲级真题(DFS+堆和二叉树的概念)

    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

    Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:
    For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

    Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

    Sample Input 1:
    8
    98 72 86 60 65 12 23 50
    Sample Output 1:
    98 86 23
    98 86 12
    98 72 65
    98 72 60 50
    Max Heap
    Sample Input 2:
    8
    8 38 25 58 52 82 70 60
    Sample Output 2:
    8 25 70
    8 25 82
    8 38 52
    8 38 58 60
    Min Heap
    Sample Input 3:
    8
    10 28 15 12 34 9 8 56
    Sample Output 3:
    10 15 8
    10 15 9
    10 28 34
    10 28 12 56
    Not Heap

    -----------------------------------------------------------

    注意:

    完全二叉树的定义:若设二叉树的深度为h,除第h层外,其他各层(1~h-1)的节点数都达到最大个数,第h层所有节点都连续集中在最左边(就是说可能会有只有左子树没有右子树的情况,按照宽度优先遍历的时候搜索到空节点时树一定已经遍历完)。完全二叉树是由满二叉树而引出来的。对于深度为k的,由n个节点的二叉树,当且仅当其每一个节点的深度都与深度为k的二叉树中编号从1到n的节点一一对应称之为完全二叉树。

     题目大意:

      给出一颗完全二叉树,打印从根节点开始到所有叶节点的路径,打印的顺序先右后坐,及先序遍历的镜像。然后判断是否是堆。

    分析:

    1.深度打印所有的路径(从右向左,及先序的镜像),vector保存一条路径上的所有节点,通过push和pop实现回溯,维护路径,index<=n是对只有左节点没有右节点的情况的特判。

    2.判断是否为堆:从第二个节点开始遍历,如果比父节点小,就不是小顶堆,如果比父节点大,就不是大顶堆。

    #include<stdio.h>
    #include<vector>
    #pragma warning(disable:4996)
    #define maxn 1004
    using namespace std;
    int n;
    int he[maxn];
    vector<int>road;
    void dfs(int index)
    {
        if (index * 2 > n) {
            if (index <= n) {
                for (int i = 0; i < road.size(); i++) {
                    printf("%d%s", he[road[i]], i == road.size()-1 ? "
    " : " ");
                }
            }//对只有左子树没有右子树的特判
    
        }
        else {
            road.push_back(index*2+1);
            dfs(index * 2 + 1);
            road.pop_back();
            road.push_back(index * 2);
            dfs(index * 2);
            road.pop_back();
        }
    }
    int main()
    {
        scanf("%d",&n);
        for (int i = 1; i <= n; i++) {
            scanf("%d", &he[i]);
        }
        road.push_back(1);
        dfs(1);
        int ismax = 1, ismin = 1;
        for (int i = 2; i <= n; i++) {
            if (he[i / 2] > he[i])ismin = 0;
            if (he[i / 2] < he[i])ismax = 0;
        }
        printf("%s",ismin ==1?"Min Heap":(ismax == 1?"Max Heap":"Not Heap"));
        getchar();
        getchar();
        return 0;
    }
  • 相关阅读:
    Linux虚拟机突然网络不能用了但是主机能ping㣈
    010商城项目:商品类目的选择——Dao,Service.Action层的分析
    009商城项目:商品类目的选择——1前端页面分析
    《深入理解Java内存模型》读书总结
    java多线程系类:JUC线程池:06之Callable和Future(转)
    Spring中,关于IOC和AOP的那些事
    程序员面试,为什么不要大谈高并发?
    Java 面试宝典!并发编程 71 道题及答案全送上!
    面试必问的并发编程知识点,你知道多少?
    程序员必知的七种并发编程模型
  • 原文地址:https://www.cnblogs.com/zxzmnh/p/11629929.html
Copyright © 2011-2022 走看看