zoukankan      html  css  js  c++  java
  • HDU 2577 分情况多维DP

    How to Type

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6787    Accepted Submission(s): 3057


    Problem Description
    Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
     
    Input
    The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
     
    Output
    For each test case, you must output the smallest times of typing the key to finish typing this string.
     
    Sample Input
    3 Pirates HDUacm HDUACM
     
    Sample Output
    8 8 8
    Hint
    The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
     
    Author
    Dellenge
     
    Source
    类似于上次写的那道可以上下右走方格的题目,也是常见的一类DP,有一种分层的思想!
    对于此题就在于Caps键在DP的过程中可能处于开/关两种,我们不妨多开一维0表示Caps键处于关闭1表示处于开启状态.
    直接地推1Ahhh,还是在喝了酒之后好开森>_<

    #include<bits/stdc++.h>
    using namespace std;
    #define inf 0x3f3f3f3f
    int dp[105][2];
    char s[105];
    int solve()
    {
    int i,j,k,sz=strlen(s);
    memset(dp,inf,sizeof(dp));
    if(islower(s[0])){
    dp[0][0]=1;
    dp[0][1]=2;
    }
    else{
    dp[0][0]=2;
    dp[0][1]=2;
    }
    for(i=1;i<sz;++i){
    if(islower(s[i])){
    dp[i][0]=min(dp[i-1][1]+2,dp[i-1][0]+1);
    dp[i][1]=min(dp[i-1][1]+2,dp[i-1][0]+2);
    }
    else{ //da xie
    dp[i][0]=min(dp[i-1][1]+2,dp[i-1][0]+2);
    dp[i][1]=min(dp[i-1][1]+1,dp[i-1][0]+2);
    }
    }
    return min(dp[sz-1][0],dp[sz-1][1]+1);
    }
    int main()
    {
    int t,n,m,i,j;
    cin>>t;
    while(t--){cin>>s;
    cout<<solve()<<endl;
    }
    return 0;
    }

  • 相关阅读:
    利用Percona monitoring for zabbix监控MySQL
    SQL Server复制故障(1)
    SQL Server事务复制搭建与同步经验
    达梦7入门技术总结--DCA级别
    机器学习:双聚类算法
    脑洞篇之我们生活在9维世界
    自动化运维:使用flask+mysql+highcharts搭建监控平台
    深度学习:Keras入门(二)之卷积神经网络(CNN)
    深度学习:Keras入门(一)之基础篇
    机器学习:特征选择
  • 原文地址:https://www.cnblogs.com/zzqc/p/6980397.html
Copyright © 2011-2022 走看看