zoukankan      html  css  js  c++  java
  • Selecting Courses

    Selecting Courses
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10627   Accepted: 4803

    Description

    It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

    There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

    Input

    The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

    Output

    For each test case, output one integer, which is the maximum number of courses Li Ming can select.

    Sample Input

    5
    1 1 1
    2 1 1 2 2
    1 2 2
    2 3 2 3 3
    1 3 3
    

    Sample Output

    4

    Source

    POJ Monthly,Li Haoyuan
    【思路】
    二分图 + 匈牙利算法 求最大匹配
    【code】
    我不知道为什么Poj scanf读入会超时,或者是因为什么别的原因。
    有dalao知道请在评论里告诉我,多谢QWQ。
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    #define N 300+10
    int map[8][13][N],match[8][13];
    int cnt,n,num,p,q;
    bool vis[8][13];
    bool path(int x)
    {
        for(int i=1;i<=7;i++)
        {
            for(int j=1;j<=12;j++)
            {
                if(!vis[i][j]&&map[i][j][x])
                {
                    vis[i][j]=1;
                    if(!match[i][j]||path(match[i][j]))
                    {
                        match[i][j]=x;
                        return true;
                    }
                }
            }
        }
        return false;
    }
    int main()
    {
        while(cin>>n&&n)
        {
            cnt=0;
            memset(map,0,sizeof(map));
            memset(match,0,sizeof(match));
            for(int i=1;i<=n;i++)
            {
                cin>>num;
                for(int k=1;k<=num;k++)
                {
                    cin>>p>>q;
                    map[p][q][i]=1;
                }
            }
            for(int i=1;i<=n;i++)
            {
                memset(vis,0,sizeof(vis));
                if(path(i))
                cnt++;
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JDBC 查询的三大参数 setFetchSize prepareStatement(String sql, int resultSetType, int resultSetConcur)
    有空必看
    SpringMVC 利用AbstractRoutingDataSource实现动态数据源切换
    FusionCharts JavaScript API Column 3D Chart
    FusionCharts JavaScript API
    FusionCharts JavaScript API
    Extjs 继承Ext.Component自定义组件
    eclipse 彻底修改复制后的项目名称
    spring 转换器和格式化
    Eclipse快速生成一个JavaBean类的方法
  • 原文地址:https://www.cnblogs.com/zzyh/p/6838237.html
Copyright © 2011-2022 走看看