zoukankan      html  css  js  c++  java
  • Feel Good

    传送门

    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 14435   Accepted: 3996
    Case Time Limit: 1000MS   Special Judge

    Description

    Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

    A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

    Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

    Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

    Input

    The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

    Output

    Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

    Sample Input

    6
    3 1 6 4 5 2
    

    Sample Output

    60
    3 5

    Source

    【解析】
    题目大意:找一个区间,区间的和乘以区间的最小值最大。
    暴力一定超时。
    我们可以对于每一个元素a[i],找到一个尽可能大的区间,使a[i]成为这个区间的最小值。
    用sum数组存前缀和,最后枚举区间即可。
    注意long long
    【code】
    #include<iostream>
    #include<cstdio>
    using namespace std;
    #define N 100050
    long long sum[N],l[N],r[N],a[N];
    long long n,L,R;
    long long ans,maxx=-1; 
    int main()
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            l[i]=r[i]=i;
            sum[i]=sum[i-1]+a[i];
        }
        a[0]=a[n+1]=-1;
        for(int i=1;i<=n;i++)
        {
            while(a[i]<=a[l[i]-1])
            l[i]=l[l[i]-1];
        }
        for(int i=n;i>=1;i--)
        {
            while(a[i]<=a[r[i]+1])
            r[i]=r[r[i]+1];
        }
        for(int i=1;i<=n;i++)
        {
            ans=(sum[r[i]]-sum[l[i]-1])*a[i];
            if(ans>maxx)
            {
                maxx=ans;
                L=l[i];
                R=r[i];
            }
        }
        printf("%lld
    %lld %lld",maxx,L,R);
        return 0;
    }
  • 相关阅读:
    类加载机制与反射(一)
    Java注解
    Tomcat部署多个项目及相关配置
    Tomcat安装阿里云免费证书
    Java泛型
    Java解析和生成XML
    枚举类
    类成员
    成员变量的初始化和内存中的运行机制
    数据仓库与数据挖掘(一)
  • 原文地址:https://www.cnblogs.com/zzyh/p/6852056.html
Copyright © 2011-2022 走看看