zoukankan      html  css  js  c++  java
  • poj 2142 The Balance

    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 9413   Accepted: 4080

    Description

    Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
    You are asked to help her by calculating how many weights are required. 

    Input

    The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
    The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

    Output

    The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
    • You can measure dmg using x many amg weights and y many bmg weights. 
    • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
    • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

    No extra characters (e.g. extra spaces) should appear in the output.

    Sample Input

    700 300 200
    500 200 300
    500 200 500
    275 110 330
    275 110 385
    648 375 4002
    3 1 10000
    0 0 0

    Sample Output

    1 3
    1 1
    1 0
    0 3
    1 1
    49 74
    3333 1

    题解:显然解方程就行ax+by=c;输出满足abs(x)+abs(y)最小的x,y; 
    然后就可以用拓展欧几里得分别求出最小的正整数x,然后带入方程求出对应的y,然后再用拓展欧几里得求最小正整数y,带入方程求对应的x。再将得到的两种(x+y)的值比较,输出小的。

    #include<iostream>
    #include<math.h>
    #include<algorithm>
    #define ll long long
    using namespace std;
    ll x,y;
    void exgcd(ll a, ll b, ll &x, ll &y)    //拓展欧几里得算法
    {
        if(!b) 
            x = 1, y = 0;
        else
        {
            exgcd(b, a % b, y, x);
            y -= x * (a / b);
        }
    }
    
    ll gcd(ll a,ll b)
    {
        return b==0?a:gcd(b,a%b);
    }
    
    int main()
    {
        ll a,b,c,r;
        while(scanf("%lld%lld%lld",&a,&b,&c))
        {
            if(a==0&&b==0&&c==0)
                break;
            ll s,ss;
            r=gcd(a,b);
            exgcd(a,b,x,y);
            s=b/r,ss=a/r;
            x=x*c/r;
            y=y*c/r;
            ll x1,y1,x2,y2;
            x1=(x%s+s)%s;
            y1=(c-a*x1)/b;
            if(y1<0)
                y1=-y1;
            y2=(y%ss+ss)%ss;
            x2=(c-y2*b)/a;
            if(x2<0)
                x2=-x2;
            if(x1+y1<x2+y2)
                cout<<x1<<' '<<y1<<endl;
            else
                cout<<x2<<' '<<y2<<endl;
        }
        return 0;
    
    }
  • 相关阅读:
    域名ICP备案个人备案写网站名称注意事项
    关于域名备案的注意事项
    MySQL里默认的几个库是干啥的?
    Python 1.3 元组与文件
    PTA(BasicLevel)-1006换个格式输出整数
    数据结构与算法-图的最短路径Dijkstra
    PTA(Basic Level)-1002 写出这个数
    PTA(Basic Level)-1076 Wifi密码
    C程序设计语言笔记-第一章
    谁能笑到最后,约瑟夫环-Josephus问题求解
  • 原文地址:https://www.cnblogs.com/-citywall123/p/10707933.html
Copyright © 2011-2022 走看看