zoukankan      html  css  js  c++  java
  • HDU 3555 Bomb 数位dp

    Bomb

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 3716 Accepted Submission(s): 1298


    Problem Description
    The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
    Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
     
    Input
    The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

    The input terminates by end of file marker.
     
    Output
    For each test case, output an integer indicating the final points of the power.
     
    Sample Input
    3 1 50 500
     
    Sample Output
    0 1 15
    Hint
    From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
    代码加注释:
    //数位DP//包含多少个49
    #include<iostream>
    #include<cstdio>
    using namespace std ;
    long long dp[35][3] ;
    int len[25] ;
    void init()
    {
        dp[0][0]=1;
        dp[0][1]=dp[0][2]=0;
        for(int i=1;i<25;i++)
        {
            dp[i][0]=10*dp[i-1][0]-dp[i-1][1];//在前面加0~9的数字,减掉在9前面加4
            dp[i][1]=dp[i-1][0];//最高位加9
            dp[i][2]=10*dp[i-1][2]+dp[i-1][1];//在本来含有49的前面加任意数,或者在9前面加4
        }
    }
    long long dfs( long long n)
    {
        int i , s = 0 , j , ok = 0 ;
        long long ans = 0 ;
        while(n)// 把各个位存到数组里面
        {
            len[++s] = n % 10 ;
            n /= 10 ;
        }
        len[s+1] = 0 ;
        for( i = s ; i >= 1 ;i-- )
        {
            ans += dp[i-1][2] * len[i] ; // 下一个是49所以这位都是符合答案的
            if(ok) ans += dp[i-1][0] * len[i] ;//
            else
            {   // 如果是大于4 则 需 下位是9
                if(len[i]>4) ans+=dp[i-1][1];
            }
            // 上位是4 ,这位是9 ,下次来都是
            if(len[i+1]==4&&len[i]==9)ok = 1 ;
        }
        if(ok)ans++ ; //最后加上最后一位
        return ans ;
    }
    int main()
    {
        init() ;
        int i , T ;
        long long n ;
        cin >> T ;
        while( T-- )
        {
            cin >> n ;
            cout << dfs(n) << endl ;
        }
    }
  • 相关阅读:
    dynamics crm 2011升级过程中发现的一些问题
    报价单上的“创建订单”按钮Disabled
    C/C++ Qt TableDelegate 自定义代理组件
    C/C++ Qt TabWidget 实现多窗体创建
    C/C++ Qt MdiArea 多窗体组件应用
    C/C++ Qt Tree与Tab组件实现分页菜单
    C/C++ Qt ListWidget 增加右键菜单
    C/C++ Qt StatusBar 底部状态栏应用
    C/C++ Qt TableWidget 表格组件应用
    VS2012 + Qt 4.8.3 + OpenSSL
  • 原文地址:https://www.cnblogs.com/20120125llcai/p/3119390.html
Copyright © 2011-2022 走看看