zoukankan      html  css  js  c++  java
  • zoj 2193 Window Pains

    Window Pains
    Time Limit: 2 Seconds      Memory Limit: 65536 KB
    
    Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows:
    1     1     .     .
    1     1     .     .
    .     .     .     .
    .     .     .     .
        
    .     2     2     .
    .     2     2     .
    .     .     .     .
    .     .     .     .
        
    .     .     3     3
    .     .     3     3
    .     .     .     .
    .     .     .     .
    .     .     .     .
    4     4     .     .
    4     4     .     .
    .     .     .     .
        
    .     .     .     .
    .     5     5     .
    .     5     5     .
    .     .     .     .
        
    .     .     .     .
    .     .     6     6
    .     .     6     6
    .     .     .     .
    .     .     .     .
    .     .     .     .
    7     7     .     .
    7     7     .     .
        
    .     .     .     .
    .     .     .     .
    .     8     8     .
    .     8     8     .
        
    .     .     .     .
    .     .     .     .
    .     .     9     9
    .     .     9     9
    
    When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1 and then window 2 were brought to the foreground, the resulting representation would be:
    1     2     2     ?
    1     2     2     ?
    ?     ?     ?     ?
    ?     ?     ?     ?
        If window 4 were then brought to the foreground:     
    1     2     2     ?
    4     4     2     ?
    4     4     ?     ?
    ?     ?     ?     ?
    
    . . . and so on . . .
    
    Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
    
    Input
    
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
    
    A single data set has 3 components:
    
        Start line - A single line:
    
                 START
              
    
        Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
        End line - A single line:
    
                 END
              
    
    After the last data set, there will be a single line:
    
       ENDOFINPUT
    
    Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
    
    Output
    
    For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement:
    
       THESE WINDOWS ARE CLEAN
    
    Otherwise, the output will be a single line with the statement:
    
       THESE WINDOWS ARE BROKEN
    
    Sample Input
    
    START
    1 2 3 3
    4 5 6 6
    7 8 9 9
    7 8 9 9
    END
    START
    1 1 3 3
    4 1 3 3
    7 7 9 9
    7 7 9 9
    END
    ENDOFINPUT
    
    Sample Output
    
    THESE WINDOWS ARE CLEAN
    THESE WINDOWS ARE BROKEN
    Source: South Central USA 2003

    //确定每个格子的可能出现数字、然后建图
    //拓扑排序
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    #include <math.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    vector <int> v[17];
    int in[10];
    vector <int> d[10];
    void Set()
    {
        v[1].push_back(1);
        v[2].push_back(1);v[2].push_back(2);
        v[3].push_back(2);v[3].push_back(3);
        v[4].push_back(3);
        v[5].push_back(1);v[5].push_back(4);
        v[6].push_back(1);v[6].push_back(2);v[6].push_back(4);v[6].push_back(5);
        v[7].push_back(2);v[7].push_back(3);v[7].push_back(5);v[7].push_back(6);
        v[8].push_back(3);v[8].push_back(6);
        v[9].push_back(4);v[9].push_back(7);
        v[10].push_back(4);v[10].push_back(5);v[10].push_back(7);v[10].push_back(8);
        v[11].push_back(5);v[11].push_back(6);v[11].push_back(8);v[11].push_back(9);
        v[12].push_back(6);v[12].push_back(9);
        v[13].push_back(7);
        v[14].push_back(7);v[14].push_back(8);
        v[15].push_back(8);v[15].push_back(9);
        v[16].push_back(9);
    }
    bool topsort()
    {
        int i,k,l;
        stack<int>S;
        for(i=1;i<=9;i++)
         if(in[i]==0)
          S.push(i);  //printf("%d ",in[i]),
        while(!S.empty())
        {
            k=S.top();S.pop();
            l=d[k].size();
            //printf("%d ",l);
            for(i=0;i<l;i++)
              if(--in[d[k][i]]==0)
                  S.push(d[k][i]);
        }
       for(i=1;i<=9;i++)
         if(in[i])
          return false;
      return true;
    }
    int main()
    {
    
        int n,l;
        int i,k;
        char op[12];
        Set();
        while(scanf("%s",op))
        {
            if(strcmp(op,"START")!=0) break;
            memset(in,0,sizeof(in));
            for(i=1;i<=16;i++)
             {
                 scanf("%d",&n);
                 l=v[i].size();
                 for(k=0;k<l;k++)
                  if(v[i][k]!=n)
                  {
                      d[n].push_back(v[i][k]);
                      in[v[i][k]]++;
                  }
             }
             scanf("%s",op);
             if(topsort())
               printf("THESE WINDOWS ARE CLEAN\n");
             else
               printf("THESE WINDOWS ARE BROKEN\n");
            for(i=1;i<10;i++)
             d[i].clear();
        }
        return 0;
    }


  • 相关阅读:
    CentOS7中Tomcat的安装和配置
    CentOS7中JDK的安装和配置
    Linux基本指令
    MySQL数据库索引:索引介绍和使用原则
    MongoDB基础篇2:数据库/用户/数据集合的增删改
    MongoDB基础篇1:安装和服务配置
    JSTL fn:replace()函数替换 换行符
    LeetCode440. 字典序的第K小数字
    kubeadm搭建kubernetes-1.13.2集群
    kubernetes(k8s)kubectl使用详解
  • 原文地址:https://www.cnblogs.com/372465774y/p/2766278.html
Copyright © 2011-2022 走看看