zoukankan      html  css  js  c++  java
  • PAT 1091. Acute Stroke (bfs)

    One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

    Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

              
                 Figure 1

    Output Specification:

    For each case, output in a line the total volume of the stroke core.

    Sample Input:

    3 4 5 2
    1 1 1 1
    1 1 1 1
    1 1 1 1
    0 0 1 1
    0 0 1 1
    0 0 1 1
    1 0 1 1
    0 1 0 0
    0 0 0 0
    1 0 1 1
    0 0 0 0
    0 0 0 0
    0 0 0 1
    0 0 0 1
    1 0 0 0

    Sample Output:

    26

    分析

    这道题意我实在看不懂就去查了别人的题解,意思是输入给的是一组三维坐标,每个坐标的值是0或1,然后通过bfs进行探索,记录连续碰到1的路径长度,只记录那些大于等于t的,注意,在bfs进行广度搜索时,上,下,左,右,前,后六个方向,还有注意坐标不要超过边界以及只遍历值为1的点。

    #include<iostream>
    #include<queue>
    using namespace std;
    struct node{
    	int x, y, z;
    };
    int m,n,l,t;
    int arr[1300][130][80];
    bool visited[1300][130][80];
    int X[6] = {1, 0, 0, -1, 0, 0};
    int Y[6] = {0, 1, 0, 0, -1, 0};
    int Z[6] = {0, 0, 1, 0, 0, -1};
    bool judge(int x,int y,int z){
    	if(x < 0 || x >= m || y < 0 || y >= n || z < 0 || z >= l) return false;
    	if(arr[x][y][z]==0||visited[x][y][z]==true) return false;
    	return true;
    }
    int bfs(int x,int y,int z){
    	int cnt=0;
    	node temp;
    	temp.x=x; temp.y=y; temp.z=z;
    	queue<node> q;
    	q.push(temp);
    	visited[x][y][z]=true;
    	while(!q.empty()){
    		node top=q.front();
    		q.pop();
    		cnt++;
    		for(int i=0;i<6;i++){
    			int tx=top.x+X[i];
    			int ty=top.y+Y[i];
    			int tz=top.z+Z[i];
    			if(judge(tx,ty,tz)){
    				visited[tx][ty][tz]=true;
    				temp.x = tx, temp.y = ty, temp.z = tz;
    				q.push(temp);
    			}
    		}
    	}
    	if(cnt>=t)
    	   return cnt;
    	else 
    	   return 0;
    }
    int main(){
    	cin>>m>>n>>l>>t;
    	for(int i=0;i<l;i++)
    	    for(int j=0;j<m;j++)
    	        for(int k=0;k<n;k++)
    	            cin>>arr[j][k][i];
    	int ans=0;;
    	for(int i=0;i<l;i++)
    	    for(int j=0;j<m;j++)
    	        for(int k=0;k<n;k++)
    	            if(visited[j][k][i]==false&&arr[j][k][i]==1)
    	               ans+=bfs(j,k,i);
    	cout<<ans;
    	return 0;
    } 
    
  • 相关阅读:
    如何解决MathPage.wll或MathType.dll文件找不到问题
    2-构建模型
    R语言 ur.df函数(2)
    平稳过程趋势项变点的 CUSUV 检验 秦瑞兵,郭娟
    时间序列的弱相依与强相依
    Cent OS|使用httpd发布网页
    C++练习 | 基于栈的中缀算术表达式求值(double类型
    C++练习 | 不使用头插法逆转单链表
    C++练习 | 单链表的创建与输出(结构体格式)
    C++练习 | 最长公共字符串(DP)
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/8416349.html
Copyright © 2011-2022 走看看