zoukankan      html  css  js  c++  java
  • PAT 1119 Pre- and Post-order Traversals

    Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

    Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

    Output Specification:
    For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input 1:
    7
    1 2 3 4 6 7 5
    2 6 7 4 5 3 1

    Sample Output 1:
    Yes
    2 1 6 4 7 3 5

    Sample Input 2:
    4
    1 2 3 4
    2 4 3 1

    Sample Output 2:
    No
    2 1 3 4

    #include<iostream>//比较难,由前序和后序遍历来确定二叉树,参考了柳婼的
    #include<vector>
    using namespace std;
    vector<int> pre, post, in;
    bool unique=true;
    void getin(int prel, int prer, int postl, int postr){
      if(prel==prer){
        in.push_back(pre[prel]);
        return ;
      }
      if(pre[prel]==post[postr]){
        int i=prel+1;
        while(i<=prer&&pre[i]!=post[postr-1]) i++;
        if(i-prel>1)
          getin(prel+1, i-1, postl, postl+i-prel-2);
        else
          unique=false;
        in.push_back(pre[prel]);
        getin(i, prer, postl+i-prel-1, postr-1);
      }
    }
    int main(){
      int n;
      cin>>n;
      pre.resize(n), post.resize(n);
      for(int i=0; i<n; i++)
        cin>>pre[i];
      for(int i=0; i<n; i++)
        cin>>post[i];
      getin(0, n-1, 0, n-1);
      unique==true?cout<<"Yes"<<endl<<in[0]:cout<<"No"<<endl<<in[0];
      for(int i=1; i<in.size(); i++)
        cout<<" "<<in[i];
      cout<<endl;
      return 0;
    }
    
  • 相关阅读:
    ElasticSearch--------->附录------->curl------->附录一:下载、安装、配置cURL
    ElasticSearch--------------------->step2,了解elasticsearch相关的基本概念
    1. anaconda安装与配置
    js 浮点型数据运算
    2.0 VMware安装教程
    2.2 es6之Promise对象
    代理模式
    oracle原始对象
    锁理论
    策略模式
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502076.html
Copyright © 2011-2022 走看看