zoukankan      html  css  js  c++  java
  • hiho一下 第148周

    题目1 : Font Size

    时间限制:10000ms
    单点时限:1000ms
    内存限制:256MB

    描述

    Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

    Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

    So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

    输入

    Input may contain multiple test cases.

    The first line is an integer TASKS, representing the number of test cases.

    For each test case, the first line contains four integers N, P, W and H, as described above.

    The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.

    For all test cases,

    1 <= N <= 103,

    1 <= W, H, ai <= 103,

    1 <= P <= 106,

    There is always a way to control the number of pages no more than P.

    输出

    For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

    样例输入
    2
    1 10 4 3
    10
    2 10 4 3
    10 10
    样例输出
    3
    2

    题目很简单,就是找最大符合条件的p。把题目看懂,枚举似乎也可以过。

    这里,我用二分省了一部分时间,也许有更好的优化。。菜鸟我就没有去想了。

    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    const int maxn = 1e6+5;
    ll T, n, w, h, pp;
    ll p[maxn];
    
    bool ok(ll s) {
        ll c_num = w/s, l_num = h/s, cnt = 0;
        if( c_num<=0 || l_num<=0 ) return false;
        for(int i=0; i<n; i++) {
            if( c_num == 1 ) cnt += p[i];
            else cnt += (p[i]+c_num-1)/c_num;
        }
        return ( cnt + l_num - 1 ) / l_num <= pp;
    }
    
    int main(){
        cin >> T;
        while( T -- ) {
            cin >> n >> pp >>  w >> h;
            for(int i=0; i<n; i++) cin >> p[i];
            ll l = 0, r = min(w, h), m;
            while( l < r ) {
                m = (l+r)/2;
                if( ok(m) ) l = m+1;
                else  r = m-1;
            }
            while( !ok(l) ) l--;
            cout << l << endl;
        }
        return 0;
    }
  • 相关阅读:
    linux中按行读取指定行
    linux常用配置文件
    linux虚拟机设置网络
    jenkins新建一个robot脚本的job
    jenkins中配置邮件发送
    jenkins中robot framework插件安装
    Jenkins subversion svn插件安装失败
    jenkins节点启动
    {"non_field_errors":["Unable to log in with provided credentials."]}% 无法使用提供的凭据登录
    路径模板
  • 原文地址:https://www.cnblogs.com/Asimple/p/6792719.html
Copyright © 2011-2022 走看看