zoukankan      html  css  js  c++  java
  • UVA 10129 Play on Words

    Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

    Input

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

    Output

    Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. If there exists such an ordering of plates, your program should print the sentence ‘Ordering is possible.’. Otherwise, output the sentence ‘The door cannot be opened.’

    Sample Input

    3

    2

    acm

    ibm

    3

    acm

    malform

    mouse

    2

    ok

    ok

    Sample Output

    The door cannot be opened.

    Ordering is possible.

    The door cannot be opened.

    感谢大佬们的思路及代码。原来字符也可以并查集。长见识了。

     //Asimple
    #include <bits/stdc++.h>
    #define INF (1<<20)
    #define mod 10007
    #define swap(a,b,t) t = a, a = b, b = t
    #define CLS(a, v) memset(a, v, sizeof(a))
    #define debug(a)  cout << #a << " = "  << a <<endl
    using namespace std;
    typedef long long ll;
    const int maxn = 30+5;
    const double PI=atan(1.0)*4;
    ll n, m, res, ans, len, T, k, num, sum, l;
    int fa[maxn];
    int ind[maxn], oud[maxn];
    int rk[maxn];
    
    void init(){
        CLS(ind, 0);
        CLS(oud, 0);
        for(int i=0; i<maxn; i++){
            fa[i] = i;
            rk[i] = 0;
        }
    }
    
    int find_set(int x){
        return fa[x]= (fa[x]==x?x:find_set(fa[x]));
    }
    
    void make_set(int x, int y){
        x = find_set(x);
        y = find_set(y);
        if( rk[x]>rk[y] ) {
            fa[y] = x;
        } else {
            if( rk[x]==rk[y] ) rk[y]++;
            fa[x] = y;
        }
    }
    
    void solve(){
        bool f = true;
        int cnt = 0;
        for(int i=0; i<maxn; i++) {
            if( (ind[i] || oud[i] ) && fa[i]==i) cnt ++;
        }
        if( cnt!=1 ) f = false;
        int sumin=0, sumou=0;
        for(int i=0; i<maxn; i++) {
            if( !f ) break;
            if( ind[i]!=oud[i] ){
                if( ind[i]==oud[i]+1) sumin ++;
                else if( oud[i]==ind[i]+1 ) sumou++;
                else f = false;
            }
        }
        if( sumin && sumou && sumin+sumou>2 ) f = false;
        if( f ) cout << "Ordering is possible." << endl;
        else cout << "The door cannot be opened." << endl;
    }
    
    void input() {
        ios_base::sync_with_stdio(false);
        cin >> T;
        while( T -- ) {
            cin >> n;
            init();
            for(int i=0; i<n; i++) {
                string str;
                cin >> str;
                int a = str[0]-'a', b=str[str.length()-1]-'a';
                oud[a]++;
                ind[b]++;
                make_set(a, b);
            }
            solve();
        }
    }
    
    int main(){
        input();
        return 0;
    }
  • 相关阅读:
    洛谷-P1855 榨取kkksc03
    Error: ORA-06502: PL/SQL: 数字或值错误 : character string buffer too small(触发器中使用系统动态视图导致)
    jwt ctf
    apktool+nuclei mobile
    Subdomain Takeover via Fastly ( Steps )
    乱七八糟
    Recon
    推荐几个我感觉不错的tips
    子域名收集
    清除Cookie的数据
  • 原文地址:https://www.cnblogs.com/Asimple/p/6847152.html
Copyright © 2011-2022 走看看